Start a new topic

Sonoff SmartSwitches do not connect to the strongest signal channel/AP

Dear all,


I can pair and connect any Sonoff device without problem. (2.4Ghz, ... are not an issue). The experience below has been confirmed with BASICR2, and 4CHPROR3.


The issue I have is that the Sonoff devices do not select the strongest channel/signal in a mesh network which results into unpredictable connectivity behavior.


In more details, mesh networks offer the possibility to have a single wifi network name (aka SSID), offered by multiple access points (APs) across my home. Behind the scene this works by having each APs offer a non overlapping Channel RF. In my case my home has 3 APs - and for a reason I cannot fathom all my Sonoff devices connect to an AP with Channel 11, which is far away.

-> Even when opening them out of the factory box, pairing them with a phone on the right AP, sonoff devices somehow select a weaker/placed further AP.


My questions are

1) Could the sonoff connect to the strongest AP signal for a given SSID? How ?

2) Could I influence with the app the AP that the sonoff will connect to ? How ?


The net result is that one of the most useful Sonoff is only connected with -14Db, and at times seems to disconnect.


Thanks in advance, Karim

1 Comment

For everyone's visibility. Sonoff confirmed 1) and 2) are not possible with Sonoff. The solution was then to do to the Mesh Router controller settings, and force the 2.4Ghz channel that the Sonoff seem to like to the AP I wanted them to connect to. Option 2, add another SSID for only one AP that you want them to connect to.

Login or Signup to post a comment