Start a new topic

Fixed: Connection to Google home not working, error: "Couldn't update the settings. Check your connection"

I found the problem with my google/EWE smart app connectivity (unable to add Smart We Link app) 

I have been struggling to re-connect my Sonoff devices to my Google Home app always getting error : "Couldn't  update the settings. Check your connection"


After a bit of tinkering I found the below to fix my problem:

  • I created a new  ewe profile and tried to link this account to my Google home app, this worked but showed no additional switched/devices since there was no switches added.
  • I then added all switched (shared all switches with new profile created in 1st step) and same error (error whilst syncing ewe smart app something went wrong")I removed the sharing from original profile and then added one switch/device  at a time and did a sync for each device until the problem returned. 
  • I skipped/removed this switch and added all other devices/switches. I did a final sync and all switched/devices was available except for the excluded switch.

It turn out I have a problematic 4ch Pro, I have multiple 4ch pros with all the same firmware ((Firmware PFS-B04-GL) and setup (network enabled, same naming convention....) but just the single one breaks my google/ewe sync, 

hope this helps

ewelink.JPG
(82.1 KB)
Login or Signup to post a comment