Start a new topic

DW2-WiFi unit won't pair.

What would prevent new DW2s from pairing? 

I have tried multiple different 2.4gig access point brands (Netgear, Unifi), different networks, IOS eWelink and Android eWelink. The Bluetooth device ID appears, but fails to pair after wifi SSID and password are entered. Pairing fail. 

What's troubling is the SSID all of my other Sonoff devices use is not listed in the access points when pairing, I feel like that may be the problem.   I have tried to manually enter the SSID and password - Pairing fail.

Does anyone have any advice before I return these?

iTead is on holiday until 9-Oct.

1 Comment

Hi Stu, one of my customers had the same issue, it was he had the 802.11 B protocol disabled in his access point. After enabling his SSID started showing and he could complete the pairing. 

If you see the specs in the ITEAD page it says it works on 802.11 B only while other Sonoff devices works on other bands too.

Hope this helps.

Login or Signup to post a comment