Start a new topic

DW2 not reliable enough for security.

The DW2 wifi devices are not reliable enough to use for security. It seems like the DW2 only sends a single message when it transitions from open to close or close to open. If this does not make it to the server for some reason then you will never be notified of the transition. You can wait forever and never get the message and if you look at the app it will show the wrong status. This is not a magnet issue since it does not work when going from closed (magnet present) to open where it is a far distance from the magnet. I have verified there is no blinky light indicating wifi connection issue. Also I have either 3 or 4 wifi bars indicated in the app. It seems to me that the server should send an acknowledge back to the device when the state transitions. If the acknowledge is not received within a few seconds the device should try to resend the transition message again until the acknowledge is finally received.


image


I bought 4x DW2, but failed to pair them with iOS eWeLink app and android eWeLink app. I got pairing failed (6304).


Would you possible to share some detail of your setup environment?  such as eWeLink version you used?    Android or iOS?   Router Brand? 


Thanks in advance!

Another possibility is that the magnetic sensor gets "stuck"? .  That is that it doesn't open when removed from the magnetic field?  If the magnet field is reapplied and removed then it gets unstuck?  Not sure how I would debug that. 


James,  I did not have that problem.  Make sure that the device is very close to the phone when you try to pair it. I have iOS, not sure the version of the eWelink.   I don't have notice to upgrade it so I think it must be the latest but can't find version on the app or in apple settings.  Do you have the Bluetooth on?  It uses Bluetooth to do the pairing.

James, Also you have to be on a 2.4GHz wifi network, not 5Ghz.  I don't know if this is a problem but I have had problems with other devices with wifi passwords that have special characters.  Maybe try to turn off PW protection on you wifi and try it like that just to see if you can pair.


Thanks Dave.

I had tried few times and also follow some advises @ https://www.reddit.com/r/sonoff/comments/hybwtx/sonoff_dw2_cant_pair/
but no success

after considered all the advice, I finally get it to work with following configuration:

  1. wifi 2.4ghz must configure to Legacy
  2. wifi SSID must contain only a-z (no space)
  3. wifi password must contain number 0-9
  4. wifi channel must set to 6
  5. eWeLink app must have location service permission.

note: do reboot your router after change before pairing

after considered all the advice, I finally get it to work with following configuration:

  1. wifi 2.4ghz must configure to Legacy (b/g protection)
  2. wifi SSID must contain only a-z (no space)
  3. wifi password must contain number 0-9
  4. wifi channel must set to 6
  5. eWeLink app must have location service permission.

James.  Oh yeah now I remember that it was the SSID that had a space that was the problem I had with another device.  I can tell you however I do not have any numbers in my password just combinations of capital and small case letters.  Also I didn't have to do anything with the wifi channel.  I have location services on eWelink set to ASK.


Let me know if you run it to unreliability of reporting open/close status.

I wired a switch across the magnetic sensor and verified that it works, sometimes.  So with no magnet around I switched it several time and it works.  Then I went to the open position and it did not register.  So seems like the communications to the server.  Could be on my end but I have tried reseting the router etc.  If i throw the switch to close of course it does not register because server already thought it was closed.  If I re-open then it will register.  Maybe they are having an issue with their server?  Still seems like a flaw.  They should keep sending a open or close to the server every couple seconds until they get an acknowledge from the server that it has seen the command.  Perhaps they can send a firmware update to improve this. If not I am going to have to find another solution.  Two bad since these were inexpensive and used wifi instead of needing a bridge.


Login or Signup to post a comment