Start a new topic

TH10 won't go online after pairing

Hi,


I just bought a TH10 switch for temperature control purposes. I already have the S26 on/off switch and it works like a charm on my wireless network and in the app.


However, the TH10 has been problematic for me from the get go.

The quick pairing just didn't work. It never got connection with my 2,4Ghz network, regardless of what I did. The compatibility mode didn't work either the first 20ish attempts, but for some reason, the ITEAD SSID suddenly appeared, and after thinking for a long while, it connected and I could go next to finish the pairing.


After that, the device appears in the app but always as Offline. The led indicator blinks slowly once at a time. The device has not yet appeared in my router's device list, so probably never connected all the way.

I have since that rebooted the router, the app, power the TH10 on and off, but without change. I have even deleted it from the app and restarted the pairing, but back on the same step as above.


I only own iOS devices, unfortunately all are above iOS 13 -> 13.5.1, 13.5.1 and 13.4.1

FW name: PSA-BHA-GL
Router: Technicolor TG799VAC

WIFI: 2,4GHz with WPA-PSK password

Is it a faulty unit? Could it be a router setting?

Thankful for all help I can get.


Johan,


I do not have a TH10 but I have had many problems pairing Sonoff to EweLink. If you don't have many devices it might be worth changing the 2.4Ghz channel on your router. Furthermore if you have any Parental controls enabled such as Access or MAC Filtering switch them off and try pairing again. The latter caught me out a few times. 


I have a service ticket with Itead regarding server connections and timeouts which I believe is causing a lot of the poor pairing issues. If I get any resolution to my consistent problems I will advise you.


1 person likes this

Hi Robert,


Thanks for answering.


I tried both channel 6 and 11, since I recall that those two are the most stable and effective ones. I also tried to change the SSID name to a simpler one.


With that said, I was like 6-7 feet away from the router while configuring and troubleshooting the TH10. The S26 has no connectivity issues what so ever, even in another room 20-25 feet and two walls away.


Do you think swapping the unit to another TH10 would make any differences? Or is it wiser to look for another product/brand to avoid the same issue all over again?

Hmmnn tough one. If you have a number of Sonoff units and wish to keep using the one App then I would suggest buying another replacement. It could simply be yours is faulty. It is not pairing and then not online. I have bought a few devices such as the RF wifi modules only to find the RF works but not the wifi. When I opened them up they did not have the wifi chips and were basically mis-sold. The last lot I bought work fine once paired on my TPLink router but not on my Totolink router. I haven't figured out why yet. Take your unit to a friend house and try their router see if it works there. If not buy another one and keep the receipt so you can send it back.
Johan, did you resolve your problem? To add further to my issues I decided to bin my Totolink router and bought TPLink Deco M9 pair mesh system. All my D1 units connect and pair first time with the App now as long as you switch the 5g off on the router first. Once paired switch the 5g back on again. Everything works fine.
Login or Signup to post a comment