Start a new topic

Sonoff switch offline after new router setup

Hello everyone, I'm new to this forum here because I'm having issues getting my Sonoff switches back online after setting up my new router. 

I have read, that I would need to delete the devices in the app from the old network and then register with the new network. Unfortunately this is not possible since my old router broke.

Through the eWeLink App, I can "register" them as a new device through compatible mode and it always runs through all steps and I can name the device. 

But it afterwards they stay offline, no matter how long I wait. 

What I have tried (unsucessfully) so far:

1) Setting same SSID and password then the old router

2) Setting new SSID and password

3) Setting same SSID with new password 

4) Resetting device by holding power button for 20-80 seconds

5) Tried both pairing modes (quick pairing mode + compatible)

1 person has this problem


I have had same problem

I  removed the program from phone Galaxy S4 android ver.8

removed all data re. Ewlink. restarted phone Installed the 2,4 net wifi on the phone 

I have success by pressing the reset when powering up. push reset and hold it 6-8sek. 

after trying that I got reset the Sonoff. it was Rf + 4 Ch. +2 pc. 1 Ch. 

all is working fine and are now upgraded. :)

br. erik






Wonderful information!

I found amazing information on the blogs i suggest everyone to follow the links below to get download files from this website.





Login or Signup to post a comment