Start a new topic

EwElink unresponsive and after update

Following update to the newest version of ewelink, the response is slow or nonexistent. Need to press the button 10-20 times before relay responds turning something on or off.

Iphone 11 pro 

ios 13.3.1


Sonoff 4ch pro, newest firmware 

Sonoff basic, newest firmware 

Sonoff mini, newest firmware 

Sonoff dual, newest firmware 

in-fact, I got locked out of the garage for a day until I got it open, lost the original remote, was relaying on sonoff that worked great with the old eweling app and now it is pretty much rendered usless.

checked with some friends using sonoff devices that updated to the new firmware, they are having the same problem. It randomly does switch the relays on/off but very unconsistant.

is there a wy to revert to the old app?


1 person has this problem

Hi eWeLink,

I have many switchs Sonoff RF-R2 WIFI that works without trouble since one year, remotely controled by eWeLink (with my phone SGS3 Android 4.1.2, eWeLink 3.5.5).

Then suddenly, on 30 may 2020, impossible to get eWeLink network (it ask the email and password but never accept it). Message: Authentification failed, connect again.

So i go to the "help and feddback / network diagnostic" form, and "Start to diagnose". The test  goes to 50%, wait a long time and stop.

- Login service  X (NOK)

- Distribution service  X

- Device service  Generally OK  (effectively i get the notifications of some devices)

The trouble is the same if a use WIFI or phone DATA.

My release 3.5.5 works fine on all my phones (I tried to test with a release 4.1.0 but it is the same trouble). More recents releases, if available, don't fit on my phones. 

As there is near one week i can't control my switchs, the problem become urgent to be solved.

Can you give me a solution ?

Thanks for your answer.


Luc PERRET France

Yeah, tried emailing itead a few times for support over the past, we are going to get hard time getting support... i am actually considering Shelly to replace all of my sonoff devices (I have more thna 60 sonoff devices)....

 I emailed them once, I only have one device from them, they responded within 12 hrs.

Why are you deleting my comments itead instead of helping us out?

1 person likes this


NO REAL ANSWER to my problem .

The link  you give me (unresponsive after update) doesn't concern me because i have not made the upgrade (i'm always on 3.5.5 android version), it is absolutly useless and unworthy of your factory ! 

If you speak of YOUR internal upgrade, the less you MUST DO is to give compatibility with the old user of SONOFF switchs.

And now there are 11 DAYS i can't use my (far away) SONOFF switch because YOUR software does not work. This is UNACCEPTABLE !

However I noticed a change  in "help and feddback / network diagnostic / Start to diagnose".

Now The test  give  :  

- Login service   OK

- Distribution service  NOK

- Device service  OK  (effectively i always get the notifications of some devices)

So please correct the "distribution service" ASAP  if you want to keep your faithful old clients.


1 person likes this

I have same issue since I updated the app for iPhone to version 4.1.1.  Quite frustrating to have to try to press the button multiple times and wait to see if it actually does anything.  Only real solution I have found is going to main screen on app and pulling down to do manual refresh and then trying the button.  Most times this solves the issue for me but not always.  The application itself seems to run alright but communication with switches etc. is pretty slow to respond if it does at all and sensor readings are also slow to update.

1 person likes this

Eco-Harmonie, i have those exact same problems. It took me several day to discover that on 30 of may they did change something on servers/login. (i tinik on that date there is an update for the app too) they change something related to a SSL certificate that on some old phones we dont have...In other words they drop support for old android/phones. If you take a fres new phone, the app will work fine, but hey i dont need want a new phone just for turn on a light...Also i dont need an app to have all permision on my phone...

I play A LOT with different phones, differnet versions of ewelink, change date to 20-29 of may, open tickets to ewelink support and after several days manage to just log back in in the app, but now I am very limmited...only see device status and get notification, cannot see or make scenes, cannot control devices from app...And after all of that, some devices starts to turn on by themselfs after "support" "work" on my account...

Manage to install an emulator on PC and there the app works fine...there maybe those SSL restrictions are passed...

I think its time to drop sonoff/ewelink and get something else... They do not get you out...they force you to get out...

I'm having the same problem - reported it to iTead 2 days ago, but no response as yet.

They've always been so good in the past, maybe their staffing has been hit by Covid-19???

Login or Signup to post a comment