Start a new topic

Upgrade firm to 3.5 now house lights wont stop flashing

Hi all I have loads of sonoff mini installed controlling the house lights. Yesterday I update ewelink and then updated all firmware on the mini from 3.4.0 to 3.5.0. All went well apart from 1 which every second or less turns the hall lights on then just as quickly turns them back off constantly. I had one spare so I removed the Mini that was constantly flashing the lights on and off and replaced it. Then I upgraded the firmware to 3.5.0 and now that one is constantly flashing. Has anyone else had this??? Any ideas for a fix??? Is there anyway I can re-flash with 3.5.0 incase it didn't flash properly? ?? Is there away to put 3.4.0 back on it???

11 people have this problem

Here's a few fixes. Different one work for Different people... https://youtu.be/dxlWS1vKEDw

I had faced many problems during pandemic. I was out of many and alone in my home with my oreo. That was the toughest to e for me. As I was out of money, I started to watch Netflix in mod versions. As I have PC, that is why I started finding a site that gave me my kinda application. And then I found a website. Thank fully.

I want also for my website: NTA UGC NET Anujjindal

Here is how to fix various problems on TV related. You can watch online TV on your smartphone now with tvtap apk.

Yes, you can download all at https://igamehot.net/

Same problem here

Do you love to listen to music then you must try Spotify premium apk which one of the best platforms to listen to music

Hey I solved mine just by switching L1 to L2 on the device, cable to the switch should be on L2 to L, I think trouble is power comming from L1 is too low on 2 way swirches, in spanish, he resuelto mi caso invirtiendo L1 y L2 en el Sonoff, quedando L de el interruptor en L2, que es el cable más corto, al parecer la tensión es muy baja en L1, esto solo pasa en interruptores 2 way. Saludos desde República Dominicana, greetings from the Dominican Republic.

Same issue here, even with version 3.6.0. It is randomly blinking all the time. Created a ticket https://support.itead.cc/support/tickets/462748

Héctor de Jesús Basora Arriaga You are risking burning your house down. Yes the problem is the power is too low.. The L1 and L2 are designed for 3v so it's a very very VERY bad idea to run high voltage on 1 or 2. There are other models that use a high voltage I recommend you change to one of them..

Paul you have not understood how I solved the problem, I am not putting high voltage on L1 or L2, each three-way switch has 3 contacts L, L1, L2, all low voltage, one of the cables travels a longer distance than the others , for that reason that is the one that we must place in the output of the 3 volts in the SONOFF (S1 or S2) to correct the problem, at least in my country the switch contacts are named as L, L1, L2, and the SONOFF like S1, S2 ...


Paul no has entendido como resolví el problema, no estoy colocando alto voltaje en L1 o L2, cada interruptor de tres vias tienes 3 contactos L, L1, L2, todos de bajo voltaje, uno de los cables recorre una distancia más larga que los demás, por esa razón ese es el que debemos colocar en la salida de los 3 voltios en el SONOFF (S1 or S2) para corregir el problema, al menos en mi pais los contactos del interruptor son nombrados como L, L1,L2, y el SONOFF como S1, S2...

JUST INVERT S1 AND S2.... PROBLEM SOLVED.

I have set up few MiniR2 touch switches in the last couple of weeks. I'm too am facing the same issue.

  • I didn't use the S1 and S2.
  • I used only the Neutral In, Live In & Live Out.
  • Also, the firmware version is 3.6.0.
  • Tried with LAN control on and off.


  • But this happens only with few switches and not with everything.
  • The Mini1 is not having any issue at all also there is one R2 which too doesn't have any issue at all.


All the switches are located within metallic conduits. Earthing the boxes reduced this random switching, but still, they are there.


I'm thinking of switching to Zigbee based switches, but wonder if they too have the same issue.


Am also thinking of using some other app using DIY mode, but wanted that as a last-ditch effort.

Login or Signup to post a comment