Start a new topic

Upgrade firm to 3.5 now house lights wont stop flashing

Hi all I have loads of sonoff mini installed controlling the house lights. Yesterday I update ewelink and then updated all firmware on the mini from 3.4.0 to 3.5.0. All went well apart from 1 which every second or less turns the hall lights on then just as quickly turns them back off constantly. I had one spare so I removed the Mini that was constantly flashing the lights on and off and replaced it. Then I upgraded the firmware to 3.5.0 and now that one is constantly flashing. Has anyone else had this??? Any ideas for a fix??? Is there anyway I can re-flash with 3.5.0 incase it didn't flash properly? ?? Is there away to put 3.4.0 back on it???

9 people have this problem

Same issue for me here, turn on for a second and turn off, doing this continuously.. tried everything

1 person likes this
No rectification of this issue yet, connected device will be damaged if this is happening agaun and again... Itead.. please rectify

1 person likes this

Same here. I have several sonoff mini and after upgrading to 3.5.0 just one of them just starting blinking randomly. 


I've tried turning on and off through several ways (google home, google assistant, ewelink app, physical switch...) and reset all settings (inching, looping schedule..) and nothing seems to solve the problem.


I can't see an easy way to rollback the firmware.

Same here. I have several sonoff mini controlling light bulbs around my house. I upgraded them from 3.3.0 to 3.5.0 all at once and just two are blinking randomly. 


I've tried everything. Re-pair, turn inching on and off, setup loop... nothing seems to solve the issue.


Please, allow us to rollback firmware. 


1 person likes this
I also have the same problem and now I see that this has been happening for over a month without an official response from the manufacturer. total neglect with customers.

1 person likes this

After I updated to 3.5.0 my sonoff mini few times per hour change state:

If it is in state ON it goes to OFF for 1s, if it is in state OFF it goes for 1s ON.

I didn't find how to downgrade firmware to 3.3.1. I have replace sonoff min by the new one from the box with FW 3.3.1 and now this works stable again.

Something wrong with FW 3.5.0.


1 person likes this

Something wrong with FW 3.5.0. My room looks like a nightclub. I'm afraid that the lights will fail. RETURN to version 3.3 !!!!

The sonoff firmware is not open source so I very much doubt they'll send individuals an older version. A firmware rollback would need to be done via the app. so for that to happen everybody would get sent a downgrade option whether they had the problem or not and that just won't happen. The best we can hope for is they resolve this problem and send out a new update Paul

I have the same problem here. When i upgraded to 3.5.0 it started blinking. I think its a problem of EMC in S1/S2 contacts. It just happened in a 3-way swich. In my 2-way switch its normal

I tested by disconnecting  the trigger wires in my unit and the blinking still happens, so cannot be EMC or volt drop.  It goes weeks without an issue, today its been blinking every couple of hours...  I have three wired up, a 3.3 a 3.5 with no trigger wires and a 3.51. The 3.3 has no issues, 3.5 and 3.51 both blink... rarely at the same time though..



I have the same problem. This is so frustrating. That and the problems I'm having with the Sonoff D1 dimmer for months, I don't think they're fixing those any time soon.

Same here. Open ticket and no solution yet. Maybe if we all start a campaign against sonoff mini tô new users....

I live in Brazil, we use electrical showers. I noticed that the lights start flashing only when someone is taking a shower. This bug is so weird.

I still have one Sonoff mini in the box, maybe I can find a way to download the old firmware.

Hi Raphael, same issue with my electrical showers since I decided to upgrade from 3.4.0 to 3.5.0, sonoff mini with 3.5.0 and 3.5.1 version are very instable to electrical  interferences. I dont know if any support member is active in this thread, so I suggest to everyone to open a ticket. 

Yesterday I took a shower and the lights didn't go crazy like they "normally" do.

I noticed that the iPhone app got updated. Maybe this fixed the problem?

Can anyone confirm that this is still a problem?

Login or Signup to post a comment