Start a new topic

Sonoff T1 Weird Network Issue After Wifi Access Point Replacement

Hi,

I tried to post on here about this the other day, but it didn't appear.

I'll try and be clearer this time:

I have 4x 1-gang Sonoff T1 and 1x 3-gang Sonoff T1 having the issue.

I have 6x Sonoff S20 sockets that do NOT have an issue

I have a NodeMCU that does NOT have an issue

The devices have all been reflashed with the Arduino IDE and run a simple C application, although I have also tried the latest Tasmota firmware with exactly the same result.

Old Wifi Access Points: Netgear R7000 & EX7000

New Access Points: TP-Link EAP225


So, the problem:

With the old Netgear access points everything worked fine.

With new TP-Link access points:

1. Everything EXCEPT the Sonoff T1's connect fine

2. The Sonoff T1's get listed in the TP-Link Ocada Management app, but don't connect to the network (there is a very low initial upload/download of data, but transfer rate shows 0 MPS)

3. OK, unusual, but not weird, EXCEPT that if I remove the "main" pcb from the T1 and power it up it connects perfectly EVERY time.

4. I've powered it up near to and far from the access point and it works.

5. I then put it back in the rest of the module and it NEVER connects - even if I try with it very near to the access point (less than a metre, compared to 3-5m)

6. Using a multimeter I've confirmed the module does get 3.3v from the main unit (all of the T1's behave the same, so not likely to be a suddenly faulty load of units).

7. Signal strength is good to excellent for all the devices, so no issue there.

8. I've tried disabling the 5GHz on the new access points (even though it was also enabled on the old ones) without any difference

9. I've tried different wifi channels, but no difference.

10. As soon as i turn off new access points and turn on old ones, the Sonoff T1's all connect.


I really can't understand it, but am hoping someone has an answer.

I had thought it might be an issue with ESP8285s (used by the Sonoff T1), but i think the Sonoff S20 also uses this chip and they don't have this issue.

I had thought it might have been the metal back boxes, but only one of the T1's has a metal box - the others are all in plastic surface or dry wall boxes.

The only thing i can think of is some sort of electrical "noise" that the T1's generate that the Sonoff S20 doesn't.


Help?


Thanks,

Richie




Login or Signup to post a comment