Start a new topic

D1 switches on its own

My D1 Dimmer Module, controlled by Android app eweLink, switches on its own - apart from the timers set in the app. I already reinstalled and paired the D1 module without success.

Pairing had be difficult, too. My 9th attempt in Quick Pairing mode was successful, but did not solve the problem of randomly switching.


22 people have this problem

i removed all mentioned resistors and now it is not working neither via app and remote, so be careful...

Are there any other devices where this just works? its driving me crazy and I'd prefer to just replace. 


Chris B, I got the DM1 for the scheduling feature. I did not purchase a remote as I thought the app would be all I would need. After months of possessed lighting in my iguana enclosure I opened a trouble ticket with Sonoff who were kind enough to send me a remote. The instructions I got from Sonoff were vague, at best. After some digging, I found this on page 5 of this thread:

Andrew.l.owens
said a year ago

Step by step (assuming you already have the dimmer connected to the app, and have the latest firmware on the dimmer - currently 3.5.0 - in the app, select the dimmer by clicking on the name line, (assuming you have already been to the settings page and already clicked through the information pages), click on the “...” circle at the top right, choose “settings”, look at the top row (should show 3.5.0), scroll down to bottom row (should show PSF-BLD-GL)) then:


- turn OFF the power to the dimmer

- wait 30 seconds (to ensure the dimmer is FULLY powered down)

- hold the RF remote next to the dimmer - touching is best
- turn ON the power to the dimmer; immediately (within 5 seconds) press and HOLD one of the buttons on the remote. I always use the top left “ON” button. The dimmer should emit one beep. If no beep, start the whole sequence again.

- wait two minutes. This step is not in the instructions, but I have found it helps make the pairing more likely to succeed.

- use the remote to turn the bulb on and off using the top left and top right buttons, to prove it is paired.

- now just wait and see if the ghost switching returns. Mine generally starts within 5-30 minutes.

- if it is still ghost switching, de-pair the remote by pressing and holding the bottom left button until the dimmer beeps. Start the whole sequence again. Repeat as often as needed until the ghost switching stops (four of my dimmers took 3 or 4 attempts, one dimmer took 17!).

 Top tip: if you have more than one dimmer using the same remote, power it/them off whilst pairing the next one to avoid de-pairing one(s) already working. Be aware that powering each dimmer back on carries the risk of it messing up the pairing within the first 5 seconds - I had one dimmer beep (suggesting it had paired with “something else” (that didn't exist, I was in a shielded room)) and ghost switching can return if you are unlucky. It shouldnt happen, but I had it, so it is possible. Power them back on one at a time, and WAIT in between. I suspect there are RF emissions from the dimmer (or electrical circuit) that can interfere with each other. Patience is everything with these dimmers!



Its very interesting

rudolph

I have previously emailed Sonoff/Itead without receiving a response in regard to many flaws in various devices. Please remember that the majority of users have Day Jobs, and are not electronics Fundi's, and that products should be designed to be everything they can and should be through solely through APP option settings. Using the term DIY is confusing and should only be referred to as IFTTT mode, and NOT DIY mode. DIY mode is the Simple, Easy to Use mode that us Joe Everyday use, and it should be kept simple. If I watch another video with half baked instructions on how to pair, use, or adjust settings that is not clear and does not perform exactly as per your instructions, or I hear some electronics Fundi telling us to "Flash" this or that, or remove hardwired components on the PC board to make something work, I'm going to Shit in a Bag and send it to you by courier !!! I do hope you get my message, as I am battling with the same problem in regard to the D1 Dimmer that multiple users are having, and as other users have complained, the devices might be Cheap in US $ terms, but that they are Not Cheap in many countries where some of us live, where our local currency can be 15+ local units to one US$, which makes buying your products Not Cheap at all !!!
I baught six D1 dimmers. I experience the ghost switching issue on two of the devices. The other four devices dont have the ghost swi5ching issue. All have the same firmware version. Is there a solution to resolve the issue yet?
Good Day Herman, I take it you're also a South African like myself. Just like you, and Many other people, we have all had the same problem, which is exacerbated by very Poor instructions from ITEAD/Sonoff. I found the solution in a 3rd party instruction, which was much clearer, but sometimes still requires several attempts at deleting the device and re-installing until you get beeps from both the RF433 WiFi Bridge, AND the D1 Dimmer. I am attaching a link to the solution which I found most useful. https://www.smartlife-iot.com/uncategorized/how-to-pair-and-clear-433-mhz-remote-controller-in-sonoff-devices/
I too had the same problem as most of you, a problem which is exacerbated by Poor quality instructions from ITEAD/Sonoff. I found the best solution in this 3rd party instruction guide, but which sometimes requires several delete and re-install attempts until you hear a Beep from both the RF433 WiFi Bridge, AND the D1 Dimmer. https://www.smartlife-iot.com/uncategorized/how-to-pair-and-clear-433-mhz-remote-controller-in-sonoff-devices/

Thanks for the tip. I removed the given resistors (R6 R7 R8 R9 + R11 R12 R13 R14) and now there is no ghost switching anymore

I have the same problem with Sonoff Dimmer D1, how is possible such big company to not respond to the demands of their customers We NEED a firmware upgrade to Fix D1 Bugs. please ask Sonoff to send a firmware upgrade so not forget the people than spend money on your products
I live in a remote area away from all the usual RF interference. I have 2 D1 dimmers and paired remotes. I get the same ghost switching as everybody else. I have tried swapping the remotes. I have tried new routers. I have tried different IP addresses. I have run them without connection to the internet. Nothing solves the problem. They are now trashed. I swapped them for Smart Life products i.e. Tuya and they, like all my other systems, connect easily and have never given any problems. I can control them flawlessly at home or away and they seem to work with App even if my phone is connected to 5g frequencies.
I'm sorry to see so many people with the same problem I previously experienced. Yes there is quite often a problem pairing the D1 dimmer, and the confirmation that you are going to have a problem with ghost switching, is when you don't hear the "Beep" sound to confirm that pairing has been effectively completed. ITEAD is Notoriously bad at supporting people who have this problem, and instructions are also extremely unclear. I found a third party instruction on the internet, which was very clear and helpful in this regard, and assisted me in pairing the D1 dimmer properly to eradicate the ghost switching. You may have to repeat the third party process several times, as they do warn you, to ensure that you hear the "Beep" from the D1 dimmer itself, to ensure that it is paired properly.
Login or Signup to post a comment