Start a new topic

D1 switches on its own

My D1 Dimmer Module, controlled by Android app eweLink, switches on its own - apart from the timers set in the app. I already reinstalled and paired the D1 module without success.

Pairing had be difficult, too. My 9th attempt in Quick Pairing mode was successful, but did not solve the problem of randomly switching.


22 people have this problem

Same problem with my D1: ghost switching. Doesn’t matter what I do the result is always the same: switching randomly. Itead, please help us.

1 person likes this

Well, just for giggles I tried to re-pair the remote (with the D1’s registered in the app and internet connected); as I suspected, the remote has nothing to do with it, the dimmer is still turning on senselessly for me. Took less than 20 minutes to be possessed again. Thats it, I’m ripping these little sods out. I’ve persevered for three days, and as mentioned in my first post, tried everything I can think of to systematically eliminate possible causes. Waste of money if they cant be RELIED on to JUST F****** WORK properly. And right on cue, just as I’m writing this, they’re back on again, unbelievable.

The RF remote doesn't interfere itself with the D1 to cause the ghost switching. it's a dimmer software problem.

De-pair with a long press of the remote button (as for instructions), then be sure that the D1 is correctly registered in the app and able to reach the Internet (not sure if this is actually needed), and finally re-pair the remote.
For me this procedure worked.

 

I’ve completely disconnected the RF433, and its still doing it, so the RF433 re-pairing  can’t be the solution. I have taken the batteries out of the Rf433 to guarantee it can’t be interfering with anything.


i had come across this discussion yesterday, so tried re-pairing as one of the many things I have tried and listed in my first post. It worked for a few hours, but then the problem came back, so I have systematically eliminated everything that can possibly be causing this: I am left with the device and the app, so it can only be one of those (my money is on the device, probably firmware).


Do you know what change specifically is coming in 4.0.2, and when its due? It sounds like you have some inside information that might be useful :)

As Doctor Kildare mentioned, just de- and re-pair the RM433 remote's and all your problems are solved. I had the same problem but all 4 D1-dimmers have been working flawlessly since then. Soon the dimmer will get an update to version 4.0.2 which should also fix the issue.

I too needed the RF, therefore I had to buy the Sonoff instead of Shelly.
But once I have de-paired and re-paired the RFs, both my D1s now no longer turn on by themselves.

 

Unfortunately I do need the RF (ultimately) and I have bought the D1’s now, so dont want to have to buy again. Given how nearly these things work, it would be better if ITEAD could just make them work properly.

If you don't need an RF remote, use the Shelly dimmers that are by far better than Sonoff's.
Actually, all Shelly products are years ahead of Sonoff's...

 


1 person likes this

Yep, me too; ghost switching all the d@mn time now. I have:

- upgraded firmware (now 3.5.0)

- removed from Google home and disabled IFTTT, and unlinked from the eWeLink service)

- removed all scenes, timing, triggers etc

- removed devices (currently 5) from the eWeLink app and reconnected (just 3, one wouldnt connect after an hour of trying, resetting, failing, repeating, and one is too much effort to reinstall so I left it off until I get something reliable).

- removed the RF433 switch (and even removed the battery, because I wanted to eliminate any spurious signals)

- set the brightness to as low as it goes in the hope that if it comes on it doesnt wake me (but it comes on at full bightness)

- set the power on option to “off” (in case it was being overly sensitive to any potential power glitch, so it was restarting and coming on)

- disconnected my internet connection (just in case there was some issue with the eWeLink server of some security weakness that was getting hacked).


So, with ONLY 3 D1 dimmers and the app on my ipad, they are STILL ghost switching. No radio switches, and no external internet, so they are eliminated as possible causes. The switch time varies from a few minutes to a few hours, but its doing it constantly; I had turned one off just before starting to write this, and I have had to just turn it off again.


I can only assume the devices are just crap, or the firmware update did more harm than good as its now even more frequent. Last night I even had to remove the bulbs from two light fittings to get some sleep. Today, I am going to have to remove these devil devices, which is really disappointing, as they WERE the only ones that were working kn my UK wiring.


Does anyone from ITEAD/eWeLink really have a fix for this? Please! How hard can it be to NOT  randomly turn on??? I really want these to work as I was planning to publish my “how to make a smart home with UK wiring”, but might have to change it to “why some smart devices will drive you mad”.


2 people like this

Update: It is the 2nd day living with the D1. During the last 4 hours, D1 dimmed down from 15% to 1% 3 times on it's own. Wow. Everyday is a whole new experience with this devil-dimmer.


3 people like this

If you don't need an RF remote (the reason why I bought the D1) and maybe need a physical button, along with app control and compatibility to all the available voice assistants, Shelly Dimmer is a far better product (and smaller).


1 person likes this
I have many types of led dimmable lamps and dimmers.
The behavior of a lamp when dimmed mostly depends on the electronics inside,  I found very different results.
And consider that AFAIK the dimming type of D1 is leading edge and not trailing edge, so it's not the best for led lamps.

 

I still do not like that dimmers are not symmetrical. From 60% up, almost nothing will change.

Same bug here. No RF controller, I am just controlling the dimmer through android eWelink app. It keeps switches on its own after approximately 2 hours. Also, noticed that my led filament bulbs are flickering from 1% to 40% dimm. I used to have another no-name wifi dimmer on the same bulbs and I had never experienced this flickering effect. The only reason I switched to sonoff D1 is the "Power on state" option, but it seems like I have even more problems to handle right now... I'll give it some time to get any update that might fix the issues, otherwise I'm switching it back to the old one. 


Cheers


2 people like this

I had the same results: after re-pairing my 2 D1 with their RF remotes I had no ghost switching on for the last 8 hours.


The only difference is that I originally paired the remotes with the D1 just out of the box, before connecting to the eWelink app.

Now the re-pairing occurred with the wifi connection already established.


Let's see...:)



1 person likes this
Login or Signup to post a comment