Start a new topic

D1 switches on its own

My D1 Dimmer Module, controlled by Android app eweLink, switches on its own - apart from the timers set in the app. I already reinstalled and paired the D1 module without success.

Pairing had be difficult, too. My 9th attempt in Quick Pairing mode was successful, but did not solve the problem of randomly switching.


22 people have this problem

Quick question to anyone who still has the ghost switching problem; how far apart were your D1, RF433 (if used) and Wifi hub, both
- when initially paired together, and also 

- during operation, if different?


I’m working on a theory about the gain control in the RF circuit, which might be linked to the distance between components during either pairing or operation.

I initially paired my 2 D1s with their 2 remotes just out of the box after power and lamp connections.
No app installed yet, so no wifi connection.
Distance D1-remote when pairing no more than 30 cm.
Remotes were correctly working.
But a lot of ghost switching-on on both....

The second attempt many weeks after....
D1s were already registered in the app and correctly responding to commands (from app and Alexa), and Wifi connected.
One by one, un-paired the remotes, restarted the D1s and re-paired.
After that procedure no more ghost switching-on.
Since then there was also a firmware update but my D1s keep working correctly.

 

Excellent info Dr Kildare :). Thanks. When I’ve completed all my tests, and maybe identified a cause, I’ll report my findings. No point going off half-cocked.

I'm having the same problem. I don't own the remote control, so i can't test the re-pairing stuff.


1 person likes this

I'm having the same problem. I don't own the remote control, so i can't test the re-pairing stuff.

Raphael:

R6 R7 R8 R9 + R11 R12 R13 R14 removed, let's see how it goes
from https://github.com/arendst/Tasmota/issues/7598

Post on 25 March 2020 by “kumy”


There are some photos of the boards in the thread too.


The more I read, the more convinced I am that they have left this poor devices firmware open to all sorts of vulnerabilities. Its the age old “do the minimum to make it work” rather than “control all the things that can happen so they don't cause unexpected results”. Proper error handling and active control of unused features would make these quite robust and reliable devices in their own way, but I’m not going to venture into re-writing firmware or desoldering components to loose features.


Happy reading, and desoldering :)

Mateusz:

At this stage, I can only suggest two options for you (or anyone without the RF remote):
1) buy a remote, pair it to stop the ghost switching, then put it away if you don't need it,
2) if you want to try disabling the RF, then remove the resistors as the previous comment (apparently they can be crushed with a pair of pliers if you dont want to desolder them).

i have not proved it yet, but I suspect breaking the link between U2 and U1 on the comms board might also work (i.e. desoldering or cutting the top left pin on U2, or bottom right pin on U1). If that works, the problem is with the 590R chip, but if not, its a problem with the programming on the ES7P001 microcontroller. Unfortunately I dont have the tools to diagnose whats going on between those two chips, and I’m not prepared to risk trashing one of my dimmers to find out (as I actually want to use the RF switching).

With my tests so far, I have managed to get some sustained operation with NO ghost switching, AND I have managed to recreate ghost switching. I have a way to go to prove its all 100% repeatable, BUT I think the easiest cure at the moment is to sync with an RF remote whilst holding it REALLY close to the dimmer (like touching!). So far, even 30-50cm separation seems to risk ghost switching, but touching the remote to the dimmer whilst pairing seems to guarantee no ghost switching. I think the RF side of the control board is not rejecting false signals well enough, but getting it really close for pairing seems to get a better signal, so it seems to register the ID of the RF433 unit more reliably. As the problem is intermittent, it’ll take some more time to prove, but I’ll post more when I know.
I have a speculation...

As a D1 not paired with a remote, every time it powers on, expects an RF remote signal, then it's possible that it mistakes any RF interference/signal occurring in that moment for a remote pairing signal and tunes it.
This might explain why also non-paired D1s suffer from ghost switching...

 

 


1 person likes this

I like your thinking Dr K, but I dont think it can be that. When it pairs, it beeps; no proper RF signal, no beep, so cant be pairing to a random signal. I think it must be something to do with initialisation (or lack of) in the ES7P001 microcontroller, which is allowing it to pick up spurious signals from the 590R chip, whether or not a remote was ever paired. I havent figured out whats going on in the ES7P001 yet, as it appears from the datasheet it can run in several modes (including acting as an analogue to digital converter, which might be converting the analogue OOK/ASK into data for the other microcontrollers.


The only thing absolutely conclusive is that its not in the ESP8285 chip, as that registers ghost switches as if there was had been a commanded event, even under different firmware (Tasmota).


The ghost switching both with AND without a registered RF433 is leading me towards the firmware in the ES7P001. Maybe, just maybe, re-pairing (repeatedly!) allows it to cycle through initialising its memory enough to overcome whatever gap there is in the initialisation process.


I think I have 4 dimmers now not ghost switching. My current test cycle is trying to force a working dimmer back into ghost switching, as that will reveal more about the workings of the microcontroller (without having tools to actually diagnose its code).

I don't remember well since long time has passed from my pairing procedure, but reading now the user manual of the remote there is no indication of confirmation beeps, only led flashing.
And as far as I know (very little indeed..) of the electronic schema of the D1, I didn't notice any beeper on it, maybe there is one inside the remote?

Now I don't want to de- and re-pair again my D1s not to risk to resuscitate the ghosts...;)

 

I do not blame you for not wanting to de- and re-pair them :). If I had them working properly, I wouldn't risk it either!


Trust me, there is a “buzzer” that beeps, I’ve been de- and re-pairing often enough to know. And I have learned to hate that noise :(.

There are some pictures of the circuits on the Tasmota site;  the buzzer is on the mains power board, between the heatsink and transformer, a black disc with “+” moulded into the top. There is also an 8 pin link between the boards - it is labeled “buzzer” on the wifi board. Also, in my dimmer instructions, page 10 states “Short press any button on the RF433 remote controller within 5s after powering on until you hear ‘Bi’, which indicates all buttons are paired successfully”. [I assume their word ‘Bi’ is what native English speakers would interpret as ‘Beep’]?


Still, I am glad you have working dimmers now. Maybe soon I will as well, but I am always going to have that doubt unless I can prove its not going to happen again (and we all know how hard it is to prove a negative case).


Thanks for your continuing contributions - ANY information is useful to a blind man.

png
png

Right, latest update: 

- I have managed to fix the problem to what I BELIEVE to be a reliable state (only more time will prove) by REPEATEDLY re-pairing the remote to the dimmer
- the problem is NOT signal strength as I first suspected. I have one dimmer working reliably that I managed to pair from at least three meters away, and with lots of metal in between the remote and dimmer. The antenna in the dimmer is feable, but seems sufficient to get a workable signal, althouh I do now hold it REALLY close when pairing as its still MORE.

- I believe the problem lies in the way one of the microcontrollers initialised its memory (identified more through elimination of other options than by direct proof, unfortunately). ITEAD support have not been particularly forthcoming with information, other than to suggest keep re-pairing. My tests have done that in more ways than I would have imagined when I began; I can now get a dimmer to Ghost switch, AND it seems re-pair well enough that it stops ghost switching


I am about to test that I can:

- pair with a remote to prevent ghost switching and THEN 

- remove the dimmer from being registered on my eWeLink app on one device/account AND

- register it on another device/account, without changing the RF pairing.


If that test works, then I will offer to do RF pairing in my test rig for anyone on here with the ghost switching problem who does NOT own their own RF remote. If you are interested, email me on Sonoff.Ghost.Repair@gmail.com.  It’s either that, buy your own remote, or hope that Sonoff is paying attention and actually fixes the root cause of the problem (I hope they do, it doesnt look all that hard).

Well, my last post seems to have disappeared (maybe not approved content?). Now I have proved that repeated attempts at RF pairing seems to cure the ghost switching problem, and I think that points to an error in the initialisation of the BB1 mcu firmware.


The MOST reliable way it to hold the RF device touching the dimmer whilst pairing, and if it still ghost-switches, do it again, and again (I did one 17 times! Most are three or four attempts).


I have also proved that I can connect a dimmer to my ewelink account, pair an RF remote, disconnect from my ewelink account (which it says restores it to factory settings) and STILL have the RF remote working (so its not a full factory reset). And I can then  re-connect to another ewelink account with the same RF still paired, and NO ghost switching. This last bit means I can help anyone who has ghost switching but doesnt have a remote. Let me know if you are on here and still need help :).

I borrowed this remote https://www.google.com/search?q=sonoff+pilot&client=ms-android-xiaomi-rev1&prmd=sivn&sxsrf=ALeKk02Ycz3WZTw3dSh0Vu2N749-N6qNPg:1590429643166&source=lnms&tbm=isch&sa=X&ved=2ahUKEwjS5a6PzM_pAhWPCewKHdj8DE0Q_AUoAnoECA0QAg&biw=393&bih=702&dpr=2.75#imgrc=EG_s9bLrjA7DfM from a friend. I turned off the power, then turned it on, the device gives a pairing sound after restart, you need to press one of the remote control buttons for about 5 seconds, the device will confirm the procedure of removing RF codes with a double signal. Everything is working now, no ghost switching

I have the same problem - ghost switching. No RF remote, one device only. Paired with eweLink app. 
Funny what I've noticed that D1 seems to be activated by one of RF dedicated to my son's toy :-). 


Is there already a solid solution that works if I do NOT have Sonoff RF433?

Login or Signup to post a comment