Start a new topic

D1 switches on its own

My D1 Dimmer Module, controlled by Android app eweLink, switches on its own - apart from the timers set in the app. I already reinstalled and paired the D1 module without success.

Pairing had be difficult, too. My 9th attempt in Quick Pairing mode was successful, but did not solve the problem of randomly switching.


22 people have this problem

I have the same issue.  I have raised a support ticket too.  I will let you know what they say.  Just about to take back out of the lighting circuit.

Excellent! More tickets = more likely to get a resolution. Infuriating, isn't it!

For those of you that have a remote I found a solution that works for me!  I forget where but somewhere iTead responded and said that we should hold down the bottom left button on the remote until the unit beeps to clear codes.  Then you re-pair it by cutting power for a second and then clicking the on button (top left).  I did this on both of my units a while back and it only fixed one.  I just did it again on the other and now it is fixed too.  Also on the tasmota site with issues there is a discussion about removing certain resistors to prevent the 433 chips from dimming if you dont use the remote.  I know its less than ideal but a solution for now.

"Also on the tasmota site with issues there is a discussion about removing certain resistors to prevent the 433 chips from dimming if you dont use the remote.  I know its less than ideal but a solution for now."


Can you link this, please? Didn't find it.  I'm willing to do that.

Cheers Robbz, thats one of the many things I (and a few others) have tried; at best it seems to be an unreliable fix, as whilst it may work for you and a few others, it certainly doesn't work for all of us. I am still in contact with ITEAD support to try to get a proper fix.


I’ve had them de-paired and re-paired seven or eight times, and with pulling the circuit fuse to re-power it to enable re-pairing, it got really tedious, especially when they don't always re-pair first time. I think it even worked for a day when I did it one time, but them really p!ssed me off when it started again; I too thought it had worked, but it was playing with me.


For anyone experiencing the problem, by all means try it, but dont be too surprised if it still does its own switching, and please post your results - the more information on success and failure we get, the better we can help resolve this properly.

Actually this possible solution was posted here about 1 month ago...;)

 


1 person likes this

Right, as I’ve not yet got and real answers from ITEAD support yet, I am trying a series of tests to see if I can get this to work, or isolate a cause. Rather than wire into my room lights, I have built a rig that plugs into extension sockets, so I can test the Sonoff devices in a more controlled and less time consuming way. If anyone who is still having problems has any suggestions to add to my tests, or configurations they would like specifically testing, please post a message, and I may extend my testing to accommodate your requests.


I currently have 5 D1 dimmers, 2 Slampher switches and 2 RF433 switches; the configuration I am aiming for is two rooms, each with a pair of D1’s controlled by one RF433 per room, and the Slamphers controlling the hall and landing lights (I may buy extra RF433’s for each of those, or may just trigger them in other ways, IF I can ever get past this ghost switching).


Given what I’ve already removed and disabled I can’t guess what might go wrong, as I eliminated everything I could think of, but I’m trying to be analytical about this.

My planned tests, after removing everything, even the eWeLink app from my iPad:

1) reinstall the app (with no third party apps like Google or IFTTT), and a single D1 dimmer linked to one RF433, controlling a single desk lamp.  The D1 firware had to be updated in the app, so I did that on first connection. No scenes or schedules have been set up, I just occasionally switch it on and off with the RF433 and app. I set this up on Thursday 7 May 2020, using the only D1 that I had NOT previously used (buying 5 was cheaper than the four I actually need) and so far it seems to work, 24 hours and no ghosts! I plan to run this for a week without problems before moving on to the next test (as I had thought it might work previously, but after a few days or hours, it came back to host switching). This should identify any problem with a completely isolated system (dimmer and RF switch).

2) add a second D1 (this will have to be one of the ones I have already used) for a second lamp, linked to the same RF433. This should identify if there is interference between dimmers using a common RF switch. If successful for another week, move on.

3) Add to Google Home for a week, and use the RF switch, app, and Google commands to operate the pair of lights. This should identify third party interference.

4) Add third light and dimmer, with the second RF switch. This should identify interference between RF switches.

5) Add the fourth dimmer onto the second switch.

6) Move the first room from test rig to room lighting. This should identify any issues with the physical wiring connectors, or something in the lighting circuit that might be interfering.

7) Move the second room from test to room lighting.

8) Add the Slamphers.

9) Reconnect to IFTTT.


Feel free to suggest additional steps or test if you think we might need to isolate a configuration that might possibly maybe reveal another weakness. I’m not going back to D1 without RF433 as I decided to bypass that configuration and go straight to using the RF switch, sorry (I might go back to try that at the end with my fifth dimmer, if I get that far).

I did what the guys on the Tasmota forum were discussing: removed 8 resistors from the RF circuit, since I'm not gonna use RF anyway.

It has been 24h, and no ghost switching!

I know that's not the perfect solution, but it's enough for me.

Andrew, I agree that they definitely need to fix it.  I think the issue is that when you reset it, it is picking up interference from another device at the same time.  Just a guess.  So maybe you can reduce that by removing batteries from any 433 devices you have or somehow isolating your d1 when you program it.  do you live in a multi unit house or a single unit?

Yeah, I think it must be interference, but I really dont understand how. I had problems even with the batteries out. I live in a detached property, so barely can detect wifi from my neighbours, let alone RF interference. I have some RF controlled christmas lights (not out now!) that are also 433MHz, and never get interference on those, so I’d be very surprised if its external. My working theory is that the D1 is just overly sensitive to internal triggering.


ITEAD support has suggested resetting the RF, but ensuring I DON’T power down in between reset and re-pair..


My first test seems to be going well, one D1 with one RF433 has been fine for the last 5 days. Time to add another to the same remote and see if there is cross-talk between the two D1’s. If it starts to go wrong, I’ll try the ITEAD support approach. Cant say I am optimistic though, given my experience so far.

How do you reset and re pair without powering down. That may be worth a try for me too.

I’m so glad you asked! In attempting to compose a reply, I realise its not possible! Its easy to reset with the “broken chain link” button, but the only way to re-pair seems to be to power off and on to get it in the right state to accept the pairing again.


Leave it with me - I’ll get back to ITEAD and confirm.

Maybe you can reboot the device from within the eWlink app, so without having to remove the power supply...

 

Nope, no option to do that in the app. No option to reboot, re-power or reconnect RF. Nice thought though :)

Yeah, the Sonoff eWeLink app is one of the worst IoT apps...

 

Login or Signup to post a comment