Start a new topic

D1 switches on its own

My D1 Dimmer Module, controlled by Android app eweLink, switches on its own - apart from the timers set in the app. I already reinstalled and paired the D1 module without success.

Pairing had be difficult, too. My 9th attempt in Quick Pairing mode was successful, but did not solve the problem of randomly switching.


22 people have this problem

Yep, me too; ghost switching all the d@mn time now. I have:

- upgraded firmware (now 3.5.0)

- removed from Google home and disabled IFTTT, and unlinked from the eWeLink service)

- removed all scenes, timing, triggers etc

- removed devices (currently 5) from the eWeLink app and reconnected (just 3, one wouldnt connect after an hour of trying, resetting, failing, repeating, and one is too much effort to reinstall so I left it off until I get something reliable).

- removed the RF433 switch (and even removed the battery, because I wanted to eliminate any spurious signals)

- set the brightness to as low as it goes in the hope that if it comes on it doesnt wake me (but it comes on at full bightness)

- set the power on option to “off” (in case it was being overly sensitive to any potential power glitch, so it was restarting and coming on)

- disconnected my internet connection (just in case there was some issue with the eWeLink server of some security weakness that was getting hacked).


So, with ONLY 3 D1 dimmers and the app on my ipad, they are STILL ghost switching. No radio switches, and no external internet, so they are eliminated as possible causes. The switch time varies from a few minutes to a few hours, but its doing it constantly; I had turned one off just before starting to write this, and I have had to just turn it off again.


I can only assume the devices are just crap, or the firmware update did more harm than good as its now even more frequent. Last night I even had to remove the bulbs from two light fittings to get some sleep. Today, I am going to have to remove these devil devices, which is really disappointing, as they WERE the only ones that were working kn my UK wiring.


Does anyone from ITEAD/eWeLink really have a fix for this? Please! How hard can it be to NOT  randomly turn on??? I really want these to work as I was planning to publish my “how to make a smart home with UK wiring”, but might have to change it to “why some smart devices will drive you mad”.


2 people like this
If you don't need an RF remote, use the Shelly dimmers that are by far better than Sonoff's.
Actually, all Shelly products are years ahead of Sonoff's...

 


1 person likes this

Unfortunately I do need the RF (ultimately) and I have bought the D1’s now, so dont want to have to buy again. Given how nearly these things work, it would be better if ITEAD could just make them work properly.

I too needed the RF, therefore I had to buy the Sonoff instead of Shelly.
But once I have de-paired and re-paired the RFs, both my D1s now no longer turn on by themselves.

 

As Doctor Kildare mentioned, just de- and re-pair the RM433 remote's and all your problems are solved. I had the same problem but all 4 D1-dimmers have been working flawlessly since then. Soon the dimmer will get an update to version 4.0.2 which should also fix the issue.

I’ve completely disconnected the RF433, and its still doing it, so the RF433 re-pairing  can’t be the solution. I have taken the batteries out of the Rf433 to guarantee it can’t be interfering with anything.


i had come across this discussion yesterday, so tried re-pairing as one of the many things I have tried and listed in my first post. It worked for a few hours, but then the problem came back, so I have systematically eliminated everything that can possibly be causing this: I am left with the device and the app, so it can only be one of those (my money is on the device, probably firmware).


Do you know what change specifically is coming in 4.0.2, and when its due? It sounds like you have some inside information that might be useful :)

The RF remote doesn't interfere itself with the D1 to cause the ghost switching. it's a dimmer software problem.

De-pair with a long press of the remote button (as for instructions), then be sure that the D1 is correctly registered in the app and able to reach the Internet (not sure if this is actually needed), and finally re-pair the remote.
For me this procedure worked.

 

Well, just for giggles I tried to re-pair the remote (with the D1’s registered in the app and internet connected); as I suspected, the remote has nothing to do with it, the dimmer is still turning on senselessly for me. Took less than 20 minutes to be possessed again. Thats it, I’m ripping these little sods out. I’ve persevered for three days, and as mentioned in my first post, tried everything I can think of to systematically eliminate possible causes. Waste of money if they cant be RELIED on to JUST F****** WORK properly. And right on cue, just as I’m writing this, they’re back on again, unbelievable.

Same problem with my D1: ghost switching. Doesn’t matter what I do the result is always the same: switching randomly. Itead, please help us.

1 person likes this

Well, I have removed mine for now (for my own sanity), and raised a ticket with ITEAD support. They have responded to me for previous tickets, so I hope to get to the bottom of this. Thanks  for confirming its not just me! Even though I have two completely different batches, I was still doubting myself, and thinking it was some local problem, specific to my environment. With so many reports, it looks increasingly like a product problem. We cant rely on faffing around and hoping some random magic makes them “just work”. I will keep you posted on what ITEAD comes back with.


2 people like this

@andrew.l.owens Good name btw.  My best friend also is Andrew Owens.  Can you update this thread if you hear back from Sonoff.  I am also having this problem with one of my 2 d1s

Yes, I will :). I haven't heard from them yet...


(And thanks for confirming yet another one!)

I'm having the same problem. I don't own the remote control, so i can't test the re-pairing stuff. This is a pretty pathetic problem, it completely negates the device's use. And the WAF at my house is very important, I'm losing points because of that stupid problem!

I'm also checking for updates daily.


1 person likes this
If you don't need the remote, use the Shelly dimmer which has the possibility to connect also a physical push button usable for ON/OFF/dimming.
Smaller, many more options, energy meter, secondary backup wifi, tasmota programmable.

 

Brief update for anyone following this: I just had a response to my support ticket, suggesting:

- removing the RF switch (like “Dr Kildare” suggested, and some others seem to have had success with, but certainly does NOT work for others like me) and 

- removing schedules, scenes,  and other third party software (all of which I have already done).

I have replied to ITEAD support that I have already tried those suggestions, so I am awaiting a further response. I will report back if we make progress. Keep watching this space :)

Login or Signup to post a comment