Start a new topic

Sonoff USB Micro doesn't pair

I got two pieces of a brand new product: Sonoff Micro.


I am now trying to pair Sonoff Micro with eWeLink, and both devices fail to pair with my Android eWeLink 3.14.1. Other Sonoff devices pair without problems.


After connecting to USB, both devices LED flashes quickly for 3 minutes.


When trying to pair with QR, I get:

Connect device ✓

Get device info

And it fails: Pairing failed, Cannot find device


When trying Quick pairing or Compatibility pairing, both of them find the device, but then the pairing never finishes.


When trying to connect manually to the Sonoff WiFi, there is a problem: eWeLink says that I should use password "12345678". But both my Sonoff Micro have open AP without password.


Clicking to Network diagnostics show three times OK.


I tried to debug the problem, and it seems that Sonoff USB Micro is sold with a different firmware incompatible with eWeLink.


Other devices in Compatibility mode create a WiFi AP with password 12345678, with IP addresses 10.10.7.1 (Sonoff) and 10.10.7.2 (phone). After running eWeLink, I see the device connection to my router.

http://10.10.7.1/device returns JSON with deviceid, apikey, accept and chipid chunks.


But both Sonoff Micro devices behave differently: they create an open AP without password, with IP addresses 192.168.1.1 (Sonoff) and 192.168.1.2 (phone). I see no attempt to connect to my WiFi router after running eWeLink.

http://192.168.1.1/device returns JSON with "data" chunk only.

{"data":"IcE6R ... long string skipped ... O2x"}


Is anybody else experiencing the same problem? How to proceed? I already opened a ticket, but I don't have any reply yet.


2 people have this problem

I found a new problem of Sonoff USB Micro: Even if is paired in the eWeLink using the old tablet, it does not appear in Google Home and IFTTT.

When I paired with my old device, I didn't have an issue in Google Home.


1 person likes this
hi guys, i got same issue and I used iPhone instead of android and it paired first time. thanks for hint with old android it helped me to identify that it is an issue with ewelink not micro device.

1 person likes this

Regarding the Google Home and IFTTT:

If Google Home connection with eWeLink is deleted and created again, Sonoff USB Micro will appear.

If IFTTT connection with eWeLink is deleted and created again, Sonoff USB Micro will not appear.


It seems that Coolkit goes to leave IFTTT as a free service. (I read IFTTT increased price of their services. Hopefully, now there is a chance to use eWeLink API directly.)

I solved changing settings in my wifi.
I had channel 11 forced, then I setted AUTO and it solved my issue..

Before I tried in many ways.. the app can send the right infto to micro but it cannot connect to the AP. The blue led lights once every 2 secs, it means "AP not found". That was was my solution.

Try disabling "mobile data" on your phone and retry pairing. Re-enable mobile network after successful pairing of course. I experienced this particular issue with a couple other chinese apps (ihc, etc.) and disabling my cellular network solved this kind of issue. I am guessing android is looking for the sonoff or any device to be paired in the mobile network's subnet, as it is the only one having internet while being connected to the sonoff/generic devices access point.

1 person likes this
Same problem here. Bought 2 Micros and neither would pair on my Pixel 3 (Android 10). They wouldn't get any further than 'Get device info'. Same "fix" as Kenny. I found my old Nexus 5x (Android 8) in a drawer, logged into the eweLink app and they both paired in seconds by scanning the QR code. They now appear in the eweLink app on my Pixel 3 and in Google Home. Clearly there's something in the latest Android build that the eweLink app or the Sonoff Micro disagrees with.

Conan: You found a real source of the problem. I can confirm that disabling of mobile data works.

There is yet another problem with pairing on dual band WiFi: Step 3: Device registration. When you switch to eWeLink, WiFi nearly immediately disconnects from 5 GHz AP, but it does not connect to 2.4 GHz AP. To work around this problem, there are two ways:

1. Completely turn off 5 GHz AP on the router.

2. On your phone, regularly switch between eWeLink and system WiFi Settings. There is a short race that allows to succeed.

Hi I can confirm the same issue, been trying for hours to get two of the Sonoff DIY Micro USB's to pair on both latest android and iOS. dug out an old android phone and they were both paired within seconds. Did not need to turn off ang other wifi networks. Needs fixing though please Sonoff. Phone M78 - Android 7 Kernel Version 3.18.35+ Build number M78 20171225-095038.

I can confirm I have the same issue but as Conan pointed out, just turn off your mobile data during the sync process.

Login or Signup to post a comment