Start a new topic

Sonoff camera offline/ not resetting

Had my camera for a couple of weeks and recently had it switched off for a few days. After switching back on it doesn't appear online in my app neither does it talk on boot. I've tried holding the reset button but doesn't reset either.

The two red LED's are on and the speaker seems to click every few seconds.

6 people have this problem

This also has happened to me except the two LEDS don't come on and no clicks. Have you tried another power supply?

Just sent off a support ticket.

As of July 2020, I have the same issue. I had my camera working for one month and switched it off for a few days. After switching back on it doesn't appear online in my app neither does it talk on boot. I've tried holding the reset button but doesn't reset either. 

I've also tried direct connecting it to my network with an ethernet cable and still can not get the camera to function.

As a follow-up, I did plug an ethernet cable directly into the camera and I can see that my router has assigned it an IP address.  I tried to pair it in the app using the QR code, but that didn't work either.

I have the same problem. Just switch off a day and try to power and use it again but nothing happen! No click from speaker. Red LED on! 

This is the second camera that I had and went dead after a couple of days of use. 

The first one just makes a click every few seconds.

I'm not sure about the reliability of this product!

Bought 2 but all dead now!

my problem is similar, the only difference is, that I did not switch off the camera...

the camera just stops responding (I was not able to connect to it)
reset button does not raise the RESET of the camera...

after connecting ethernet cable the camera receives IP address, I'm able to PING the address, but that's all I can do.

tried to add the camera to the APP when connected vie ethernet cable, but no success. the App is unable to discover this device on the network. I have three other Sonoff cameras and they are visible in DEVICES ON LAN section...

it seems, that initialization process stops after testing the infra LEDs... other cameras right after testing infra LEDs start saying something like "waiting for internet connection" - but this device did not say anything

any suggestions how to try resetting camera to working state?

other three devices are working fine yet (for few weeks)


I have same issue. Just received my new Sonoff camera. Setup was fast but somehow it is not displaying colour in the day. So I tied resetting it but it will not doing anything. The 2 IF less lead up for a few seconds than turned off. Any help I can get will be appreciated otherwise I have to return it for a replacement.

just received my camera. Got it paired and on my wifi. Started playing with it storing pictures and video to my phone and testing motion detection and after a few minutes, the camera went offline in ewelink. It continues to send me motion detect alerts to my phone. I tried to re start my phone, re start the camera, nothing will bring it back online. Reset it to factory defaults and re-paired it again. Then a few minutes after being online, same thing happened. it goes offline but continues to send  me email alerts. Whatever is keeping this camera "alive" in ewelink is not working.  Also, would like to know how to reset the list of push notifications.

Reliable religion & theology coursework writing services are not hard to come across for those in need of Religious Research Writing Services and theology & religion essay writing services. 

If anyone is still watching this thread and experiencing the same issue of the EWELink camera just clicking and not connecting to the wifi and not accessible. Mine started doing the same after a few months of use. I trouble-shot the issue residing with the power supply. although it is providing 5 volts, the mah is down to 3ma, where it should be 1500mah. I plugged in by bench PSU and provided 5.5v DC and it started right up, pulling around 2A. Try another PSU, the one it comes with is terrible.

Login or Signup to post a comment