Start a new topic

D1 Dimmer Module

The eWelink will not pair with D1 dimmer module. Tried several times. I have other Sonoff devices and they will only connect via compatible mode but I can  not see how you could do this with D1 module. I have an iPhone X  - Software version 13.3


1 person likes this idea

I finally managed to pair the dimmer d1 with my Iphone 11 IOS13. Quick pairing did not work. I used compatible pairing mode after I did this:

Turn on Power, turn off after 1 second

Do this 4 times and turn on the power.

(You did it turn on for 5 times now)

Go to your Iphones wifi settings and choose Itead network with password 12345678

Go to ewelink app and choose + and choose compatible pairing mode. Now enter your wifi settings and it will work

I finally managed to pair my dimmer D1 with Iphone 11 with Ios 13 to Ewelink. Quick pairing did not work. I did the following: turn on power (electricity) after 1 second turn off, turn on after 1 second turn off, turn on power (electricity) after 1 second turn off, turn on after 1 second turn off, turn on power and go to wifi settings in Iphone. You find Itead wifi. Go to Ewelink app and choose + then choose compatible pairing mode (very low on screen). Send the details of your wifi 2.4 network and it works.  It took me an hour to find it out, so I thought I should help you guys by sending this info here.

Clearing the code really helped for me. You have to order a rm433 though to do so (they aren't that expensive). Haven't had any issues since.

D1 keeps on switching on its own. Will open a thread in Bug Reports ...


1 person likes this

@Erik: Thank you for your hints, I managed to pair in Quick Pair mode (9th attempt was successful). I have to monitor the system now to see if it switches on its own or not.

@Christian: I also had trouble with quick pairing, but you just have to keep trying. Sometimes even like 10 times. Once connected to the ewelink app the dimmer worked fine until I added a rm433. It then turned on randomly. Then after clearing the code and pairing the same rm433 everything seems to work fine. I have 4 d1 dimmers/rm433 and each of them had the same problem and had to follow the same procedure (pair rm433-clear code-pair again). Now all of them have been working fine for the past few days (fingers crossed). I don't know how to clear the code without a rm433, can't help you with that.

In addition: I don´t understand why this thread is a "feature request" - it´s a bug!

Have the same problem: D1 will not pair in Quick Pairing Mode with Android eweLink app, only Compatible Pairing works. After that, it switches on its own randomly. So sad ... Sonoff tech support did not help in any way. 

@ Erik de Kroon: I don´t have RM433 remote control, do you know how I could clear the code otherwise?

Just created a discussion topic and people replied.

Hey RobbZ,

Your problem is very familiar to me. I have 4 D1's in total had the same problem. An Itead member told me to clear the code (left bottom one if I'm correct, long press till beep) on the RM433 and then pair it again. I was very doubtful to be honest this would work, but it was succesfull until now. You should try it. Can you tell me where you found the other people with this complaint? I thought I was the only one with this issue.

Yes I also have problems with my Sonoff D1's that turn on or go full brightness on their own.  Both of my D1's do this even though one of them has been updated with Tasmota firmware, so I believe that it is a problem with the 433 circuit. I have read that other people are having the same issue.


1 person likes this

I had a similar pairing problem with an iPhone.  It tells you to switch the dimmer of and on 3 times to get into quick pairing mode.  There is no instruction on how to enter compatible pairing mode but in frustration I switched it of and on in rapid succession many times - maybe 5 or 7 - and it entered compatible pairing mode.  Pairing then  worked as for other devices in compatible mode


only problem I have now is that the dimmer will spontaneously brighten at random times.  Anyone else seen this problem


1 person likes this

If you know someone who has an android phone download Ewelink app to their phone then login in to you Ewelink account and add D1 Dimmer. It should sync. Iphone will not sync for some reason.

I have the same problem.  Is this a non-working device?

I have the same problem.  Is there anyone to help

Login or Signup to post a comment