Start a new topic

D1 Dimmer Module

The eWelink will not pair with D1 dimmer module. Tried several times. I have other Sonoff devices and they will only connect via compatible mode but I can  not see how you could do this with D1 module. I have an iPhone X  - Software version 13.3

1 person likes this idea

I have exactly the same problem. I can't pair D1 dimmer module using my Iphone 7. iOS version: 13.3 Ewelink version: V3.14.1

When using compatible pairing mode, I can't find WiFi network which should be created by D1 Dimmer (ITEAD-XXXX). I use 2.4 GHz network. 

I have an Android based Samsung Tablet and loaded Ewelink on it and it added my D1 dimmer. It must be something with apple software blocking something. If someone you know has android load it onto your account via their phone.  I have a Google Nest Router plugged into a router supplied by my internet provider with 2.4Ghz so I have 2 different options to connect to. My Google Nest (2.4.Ghz as well) would not work but the connection from my internet provider would with Android. So it seems there are some bugs in Ewelink. You have the same version as me V3.14.1

I have the same problem.  Is there anyone to help

I have the same problem.  Is this a non-working device?

If you know someone who has an android phone download Ewelink app to their phone then login in to you Ewelink account and add D1 Dimmer. It should sync. Iphone will not sync for some reason.

I had a similar pairing problem with an iPhone.  It tells you to switch the dimmer of and on 3 times to get into quick pairing mode.  There is no instruction on how to enter compatible pairing mode but in frustration I switched it of and on in rapid succession many times - maybe 5 or 7 - and it entered compatible pairing mode.  Pairing then  worked as for other devices in compatible mode

only problem I have now is that the dimmer will spontaneously brighten at random times.  Anyone else seen this problem

1 person likes this

Yes I also have problems with my Sonoff D1's that turn on or go full brightness on their own.  Both of my D1's do this even though one of them has been updated with Tasmota firmware, so I believe that it is a problem with the 433 circuit. I have read that other people are having the same issue.

1 person likes this

Hey RobbZ,

Your problem is very familiar to me. I have 4 D1's in total had the same problem. An Itead member told me to clear the code (left bottom one if I'm correct, long press till beep) on the RM433 and then pair it again. I was very doubtful to be honest this would work, but it was succesfull until now. You should try it. Can you tell me where you found the other people with this complaint? I thought I was the only one with this issue.

Just created a discussion topic and people replied.

Have the same problem: D1 will not pair in Quick Pairing Mode with Android eweLink app, only Compatible Pairing works. After that, it switches on its own randomly. So sad ... Sonoff tech support did not help in any way. 

@ Erik de Kroon: I don´t have RM433 remote control, do you know how I could clear the code otherwise?

In addition: I don´t understand why this thread is a "feature request" - it´s a bug!

@Christian: I also had trouble with quick pairing, but you just have to keep trying. Sometimes even like 10 times. Once connected to the ewelink app the dimmer worked fine until I added a rm433. It then turned on randomly. Then after clearing the code and pairing the same rm433 everything seems to work fine. I have 4 d1 dimmers/rm433 and each of them had the same problem and had to follow the same procedure (pair rm433-clear code-pair again). Now all of them have been working fine for the past few days (fingers crossed). I don't know how to clear the code without a rm433, can't help you with that.

@Erik: Thank you for your hints, I managed to pair in Quick Pair mode (9th attempt was successful). I have to monitor the system now to see if it switches on its own or not.

D1 keeps on switching on its own. Will open a thread in Bug Reports ...

1 person likes this
Login or Signup to post a comment