Start a new topic

Sonoff Basic R3 DIY in DIY mode does not connect to sonoffDiy wifi

Sonoff Basic R3 DIY.
Set the jumper to DIY mode.
I connect 220V, the blue indicator blinks 1 long and 2 short
continuously. After pressing the button, the blue indicator blinks 1 short continuously and does not connect to sonoffDiy wi-fi.
What is the problem?


3 people have this question

I have the same issue.


A SonOff Basic R3 DIY with the DIY jumper in place. It doesn't connect to the SSID = sonoffDiy
PW   = 20170618sn.


I have done the same procedure with two "SonOff Mini DIY" devices without problem.


Please advice.

Same issue with a sonoff mini. First I connected with the ewe link android app successfully and updated to the latest firmware. Next I disconnected the mini from power, created the diy 2,4 ghz hotspot, placed the jumper and connected to power again. Blue led keep blinking every 2 sec. When I enable the previous wifi network again (which I used to connect to ewe link app) the sonoff mini connects immediately and is controable with the app. Even with the jumper still on
It only connects to the WiFi it was paired to. Pair again with new wifi
Why do you want to connect to new WiFi? It does not solve the problem, that Mini does not enter DIY mode and not connect to sonoffDIY mode. If you connect to new WiFi it will still be available via eWeLink, not Windows Tool. Do you mean this?
Read this, it's all about the 3.5 firmware. Complete different diy flash method. https://github.com/itead/Sonoff_Devices_DIY_Tools/issues/75. Solved it for me

Same problem (?) here:

1. Installed ewelink app
2. connected to mini
3. updates to the latest (3.5) firmware
4. installed DIY jumper
5. device keeps connecting to my home wifi, ignores DIY hotspot (tried hotspot on my android phone and on my ms surface)



And now factory reset doesn't seem to work. It's my 5th sonoff (3*basic, powR2, SlampherR2), never had a problem like this.

The 3.5 firmware is completely different (new protocol for diy Ota flash). I posted a link to a github topic about it but my post isn't moderated by itead I think.

1 person likes this

Thanks for responding. I found this

 

firmware version 3.5.0 refer to the protocol v2.0, as the set up procedure changed, the tool can not be used for the device with firmware 3.5.0. In 3.5.0, the device can be set as a AP and accessed with URL of http://10.10.7.1/

AP access point:

SSID: ITEAD-xxxxxxx
Password: 12345678

 

on their github page, but it still doesn't help - the mini keeps connecting to my home wifi whatever I do. When I press-n-hold the button in enters into 'blink-blink-blink' mode and nothing.

Thanks!

The  Sonoff basic switch does not re connect to the home WiFi network after a power failure has accrued

The device then needs to repaired by de pressing the switch.The device has worked fine up until now.


Anybody else experienced this 

Login or Signup to post a comment