Start a new topic

sonoff 5v led blinks 4 times fast

 The module was programed and working well. after a couple of days the batteries powering it died. I replaced the batteries, but the module only  flashes 4 times.cannot re connect to it. i can manually turn the relay on or off. i can also get it into flashing mode. any hel would be greatly appreciated


6 people have this question

Precisely the same problem. Anyone?
Any solution? Or do I have to buy a new one? 

Me too, I can't reset or connect any thing

Sane problem with 2 re5v and 1 basic

There is NO RESPONSE from "ITEAD Customer Care Center"

I got responce from support:
It's in factory mode which means data loss.
What happened before the problem occurs?
Did you flash the firmware?
I did nothing. No flashing or something like that. All my sonoff devices work with original firmware.
Finally I bought a new one and all works again.


Mine is also with original firmware. It is used as a garage opener and has been in an IP66 (dust and water protected) box all the time.

Thanks - Andreas Brandl

Any suggestion to solve it ?


Evan no idea what happened.

Serious: All our devices became broken at almost the same time...

I encountered the same problem as Tom Ansbro. The battery runs out. After changing the batteries, the light flashes 4 times, but the relay and inching mode still work.


I have a problem similar to yours. Is there any information about why the problem is caused or the solution?


I have not found a solution yet. Sorry! So annoying....
I received my first one yesterday and got it to connect with the WiFi and app, but whatever I tried I could not get it to learn any RF Codes or the new door sensor which I got with it. After many hours I deleted the bridge from my tablet and tried to install it on my phone, at that point it went into factory mode and I have been unable to do anything with it since. I do not think that I have done anything unusual or wrong, therefore assume it's a faulty unit. Do I need to flash it from here to get it working again? If so what with to make it function as it should? Or how do I get it out of factory mode?

i have the some problem with the TX series i haven´t used, as soon i connected to the power it stays like this. blink a few times than pauses and blink more few time and pauses again and stays like for ever. i have made a test in a room are i have a sonoff basic that is working fine.

does any one with same problem, how to fix this?

Login or Signup to post a comment