Start a new topic

Not connected to the internet

Error Message while trying the pairing "Not connected to the internet. Please check your connection and try again"

I habe connection to the internet. Another switch registered on this APP works without problems. 

3 people have this question

me too

I have iPhone

My issue exactly. 5 or 6 others work perfectly but can get some new ones or old ones I previously deleted  back on system just get 'Not connected to Internet'.

I have the same issue.

I was first believing, that i am logged in with my mobile in the 5G network, but Im in 2.4Ghz.

I cannot reach the webpage,

but i can reach the other server

How to solve this issue?

I have exactly the same problem, I'm adding my first device and have been struggling for days and the Ewelink app just says "not connected to the internet" which it is. 

 I've done some checking and the servers are down and not contactable.

It's getting to the point where I'm going to send the device back, which is a shame because the build quality is really good just a shame about the wifi configuration being awfull.

I have the same problem, just installed my Sonoff POW R2 and can't connect to it

I’ve given up with eWeLink app it’s nuts in this day an age having servers not available for days / weeks at a time. I’m in the middle of flashing the firmware with Tasmota so eliminating the need for eWeLink servers altogether.

1 person likes this

Is this an iPhone only problem? 

I can confirm that this seems to be "only" affecting iPhone users.

I was able to connect my Sonoff POWR2 via an Android phone to my account, and now I can work with it on my iPhone

1 person likes this
I’ve tried and tried and still not working. I have an iPhone so may be that. I am only a novice so can’t flash or whatever without step by step instructions. Support have been in touch asking for photos and video ? Haven’t got a clue how that will help. All my existing switches work fine I just can’t load any new - continually ‘ Not connected to the Internet’ and yet the others all work fine. Completely lost and getting no help.
I don’t have android device To confirm it’s only an iPhone issue, however After flashing the firmware this evening, it took all of 5 mins to connect to WiFi and configure direct access from Amazon Alexa, IT WORKS a dream, so I’ve ordered more, with a view of flashing firmware on everything. I’ll gladly Post all the links to the parts I purchased including the videos on how to do it.
Brilliant well done. I’ll have a go if you put the guide on . Fingers crossed. Good luck Paul

What I have done will invalidate the warranty, and stops the unit from using the eWeLink servers.

BUT it gives me what I wanted, which is direct access to the switches via an Alexa device with voice control and Alexa App.

The best video I've found so far to explain what needs to be done is:

I have the Sonoff 4CH R2:

I used the following USB to Serial Converter:

Male Pins for the circuit board:

Dupont Wires to hook everything together:

NodeMCU PyFlasher: (Both MAC and PC 32/64bit)

Tasmota Firmware:

SonOff Templates:

The only other thing you'll need is the USB cable which you may already have around the home:

Once you have flashed and rebooted, scan the network for the device' IP address and browse to it configure as per the video above with applying the right template for the device, it was really straight and all 4 switches are visible to Alexa which is what I wanted.

Hope this helps point you in the right direction.

Same issue here with Iphone and Sonoff S20

I've given up trying to use the eWeLink app, I purchased 2 more SonOff Basic switches on Saturday night received them on Sunday afternoon 10 minutes later both have Tasmota on and fully functional.

Once you've got your head around the first one, it's really easy.

Login or Signup to post a comment