Start a new topic

Sonoff RF Only Connects If I Disable WPA2 Security Completely.

It only works if I disable WPA2 security on the network completely.  Otherwise it doesn't connect to the router at all.  


It sometimes registers in the ewelink app and I get to the point where I name the device but the light on the device just keeps blinking one green per second and shows as offline in the app.


I had to twiddle around with it quite a bit but eventually I got to a point where, if I disabled WPA2 security on the network, the Sonoff RF would connect with a solid green light and I could finally control it from within the ewelink app.  


Obviously, it isn't ideal to have to completely disable my network security to get the thing to connect.  If I re-enable network security it disconnects again.  Disable network security - BOOM! - automatically reconnected again.

1 Comment

I'm using Linksys WRT3200ACM for my main router with DD-WRT firmware and WDS.  This is the one the Sonoff doesn't connect to.  


I also tested using a Linksys e4200 with stock firmware.  With the e4200 I could connect initially without WPA2 security and then re-enable the WPA2 security and the Sonoff would reconnect just fine even with the security re-enabled.

Login or Signup to post a comment