Start a new topic

TH16 - temperature stuck at 85 degree C

After upgrade from 3.3.0 to 3.3.1 temperature stuck at 85 degree C.

(205 KB)

Itead, please removed "SOLVED" status from the post submitted previously by Gerhardt. We need the firmware release fixed

3 people like this

Carl - I have reopened a new bug report.

2 people like this
3.2.2 vers All ok

I would like to downgrade to 3.2.2 version, but I have the 3.3.1 and I don't know how to revert.

1 person likes this
when will an update that corrects the temperature problem be released?
I have a problem with humidity, still 100%
At my TH10 I get the correct values of temperature and humidity at start but never update. If I reboot get correct values again but never change.

2 people like this
Solved ! Had the exact same issue, temp stuck at 85 deg, the probe does not fully insert to the th16 unit, What you need to do is widen the hole with a step drill bit, you will notice the difference straight away, when you insert the plug again, it goes further in, ever so slightly, however this makes all the difference, and the probe start reading accurately Good luck

Same problem as Rogerio except on the TH16. Humidity/Temperature is only accurate when device is turned on or the sensor is reconnected and stays at the same value/never updates.

1 person likes this

I bought a new TH10. Doing a firmware update to version 3.3.0 right at the beginning. Now I noticed that the humidity display in the app is always the same. Only after I disconnect the device from the power or I plug the sensor out and in again the value is updated.

1 person likes this

Same thing with humidity on TH16 + AM2301. It only changes on device reboot and stuck at this level until next reboot.

Quote from the Support Team:

I'm so sorry it's a problem with the software, not the hardware, the result would be the same if we send you a replacement. So we recommend waiting for the new firmware.

To the question when it comes to a new firmware update the following answer was given:
we will update the firmware version in the new year, please wait

Now it is time to wait and drink coffee
Login or Signup to post a comment