Start a new topic
Solved

TH16 - temperature stuck at 85 degree C

After upgrade from 3.3.0 to 3.3.1 temperature stuck at 85 degree C.

85c.png
(205 KB)

sonoff has to publish new FW avoid od this problem.  


1 person likes this

Hi, the problem is in sensor socket contacts. Open TH16 ant slightly push down 1st contact (photo above) and plug temp probe again.

Dear customers,


Sorry for all the inconveniences caused to you.


Our technicians are finding a solution to fix this issue. It will take some time to doing some tests to locate the reason. Please wait patiently.


Hi, any update on this? Just bought TH10, updated on first power on to 3.3.0 (latest available), and sensor reading is only 85, restarting/replugging does not help. Opened the case and gently pressed the plug connectors, doesnt solve the issue.

Pushing of contact on picture above works! I just push this contact and temperature measurement is correct!
This fix worked for me: 1. Unplug Power, Open device 2. Loosen the 4 screws on the Green Main Board 3. The Board can slighlty be moved legt/right, make Sure to Push IT as Close as possible towards the Edge where the Sensor connector is 4. Fasten the screws 5. Assemble Case 6. Now try again

Michael - did you ALSO perform the contact reset or just this board moving procedure?

@Joy Li



This is a disaster of a release - it essentially BRICKS the device.


How can we go back to previous firmware?


2 people like this
No contact reset but i bent the contacts a bit close4 together (especially the 2 where the very end/Tip contacts). That alone did Not solve it for me though, but might be in joncunction with the Board movement it did.

I would also like to go back to the previous version.

the one that worked


2 people like this

Dear friends! All that you write correctly, the testimony is restored, but not for long. When the router is overloaded, 85 degrees returns again. The most important question is why this was not the case with the old firmware. In my opinion-firmware error in the initialization of the temperature sensor. Perhaps, on the available samples in ITEAD everything works - then it's in the hardware of our devices, but judging by the fact that this is typical for TH-10 - it's in the firmware. Contacts have nothing to do with it. Just when you remove-insert the connector sensor is initialized, and then for unknown reasons is a failure.With respect


1 person likes this

I think we are discussing 2 (or more) different issues here. My issue wasn't with the firmware. I bought a new device - both with upgraded firmware and inital one - readings were only 85°. Then flashed Tasmota firmware (very easy nowadays) - only 85° readings too. By moving the mainboard as described and bending the contacts a bit the sensor started to give the proper readings. So no firmware issue here at all, but contact issue at least for my device.

Hello,
I had the same problem on 2 thermostats. I have enlarged the hole of the jack connector for a better connection to the jack. The temperature has returned to normal on the latest firmware.

image

 

Itead, when are we going to see a firmware fix for the TH10 /TH16? This is a known issue and your customers need a fix for your buggy firmware release !!!

2 people like this
Enlarging the access hole has ALWAYS been necessary since the very beginning of the TH10 and 16. The thickness of the case together with the recess of the of the female receptacle has been a problem since day one. My TH10 and TH16 devices have worked flawlessly until the last firmware release that now puts the measured temperature at 85°C

1 person likes this
Login or Signup to post a comment