Start a new topic

EWeLink don not pair dNew devices with iOS 13

After a update at iOS 13.2 is impossible to pair new devices

7 people have this problem

Thanks, Federico - I just found that thread and was able to pair but ONLY in compatibility mode.  And I had to type in the SSID, there was no scrollable list (like I think I remember from pairing attempts with other devices).  Cheers.


2 people like this
I think that this issue has been resolved as I can pair with the latest iOS no problem. Have you made sure the ewe app can access your location? For some reason, this is required.

1 person likes this

I did try the location service with no joy before pairing with an older IOS device.

So i dont think unless i done it wrong the location service fix is a fix?



1 person likes this
STILL DOES NOT WORK. I have iOS 13.5.1. Location services setting “while using”. Pairing with camera. Works for brand new camera. Completely broken when tried to move the same camera to another network. Reset doesn’t do a full reset to factory settings. None of the pairing options work: blue tooth, quick pairing, sound pairing, compatibility mode - NOTHING. Even when connecting directly to the camera's built-in WiFi. Stupid enough when accessing camera’s IP (the gateway) in the browser it doesn’t have a web interface except it shows one word “success”. It would be more appropriate to call this whole thing a big “FAILURE” and STUPIDITY of entire eWeLink app with its primitive and half-baked functionality even when it works. But unfortunately even things that supposed to work don’t work. Too bad. It was a good idea and decent hardware. A total disaster software :(

1 person likes this

I had paired with several Sonoff switches prior to my update to iOS 13.x - I updated to 13.x a couple of weeks ago and (coincidentally) I received an RF Bridge that refuses to pair, even in compatibility mode.  Once I get to the step that has you add the network name (SSID) and password, the ewelink app shows an SSID of 'WiFi' that cannot be changed, therefore it can never connect to my actual wifi SSID.  Federico - are these your symptoms?


1 person likes this
They’ve completely messed up the pairing function on iOS

1 person likes this

I've had this happen to me twice now - each time the solution was to disable/re-enable location services, then reboot my phone, then immediately perform the pairing.  Rebooting seemed to be key.

Same issue, 

New sonoff mini device, I tried to pair with an iPhone running iOS 13.2 and I only could pair with a older android tablet.

Quick Fix (iOS 13 Pair issues with Sonoff 4CH Pro):


Step 1. Ensure that your account with eWelink is properly setup and running

Step 2. Install eWelink on an Android phone (borrow from a friend if you dont have)

Step 3. Download eWelink on the Android phone and sign-in with your login details from step 1

Step 3. At this point, follow the screen setup on the android phone to complete the setup.

Step 4. On your iPhone, login using same details as in Step 1

step 5. Refresh Your screen on the iPhone by pulling down as usual and there seats your added device.


Note: 

1. Deleting the app on the Android phone after the setup will not affect the functionality of your device.

2. You will have total control on the iPhone afterwards.


This approach worked for me after 5 devices has been ordered, shipped via DHL Express (China to Nigeria) and 7 solid hours of trial/error. 


I hope it solves your challenge with the device.

@Robert Band I've all the most recent versions at the current date (iOS and eWelink app). I didn't enable the location services but now I don't need to pair the device because I used an Android device to pair. Maybe next time I can try your suggestion

Same here, enabling location services made no difference. 

Strange - because mine now works perfectly. No issues at all on latest iOS and App.

Very lucky then I guess. I've tried 3 different Sonoff devices.


I have a few more devices on the way so will give it another go.

@Private do you have an older IOS device older than IOS13?

Login or Signup to post a comment