Start a new topic

EWeLink don not pair dNew devices with iOS 13

After a update at iOS 13.2 is impossible to pair new devices

7 people have this problem

Have you made sure location access is set to “while using”? That worked perfectly for me. Without that setting, I could not pick up my Wi-Fi network to start the pairing process.
Yes, it has permission to access location while using. Since it is not working on iOS 13.3.1 and I don't have an old device with iOS 12, my only option was install ewelink app on my android tv (see attached image). Trough my android tv it worked.
I cant see it being location service i know its working for some here but from wht i can see its definitely IOS 13 thats the issue. Glad its work but thats a cool work around altho you have to tilt your head 
I have 3 TH16 devices and would like to get many more, IF I CAN get them to work!!! iPhone iOS 13.3. Don’t have an older or Android device. Google Wifi mesh Tried everything moving closers, moving far away. Don’t even see it in the WiFi option on phone.... please help..... I have been searching for something to do thing that this device should be able to do.
Hi Timothy, try install Bluestacks (an way to run Android in Windows or Mac OS, search on internet) and run ewelink on it. I think this works.

I tried to pair a sonoff with an Iphone x with IOS 13.3.1 it doesn't pair, then I tried to download the new IOS 13.4, I tried the pairing again, nothing to do. So I tryed again with an Iphone SE with IOS 13.3.1...it's works!!!

Why?


Hey, same issue here! I can’t sync any new sonoff gadgets with iOS 13.4.1, but I tried on a iPad Pro with IPadOS 13.4.1 and worked!

@Fabio Barazzutti


Maybe is a mix with iOS 13 and HW... 


Since iPhone SE uses an old HW, the problem never occurs even with iOS 13, but occurs with later models, with newer HW and iOS. F

Quick Fix (iOS 13 Pair issues with Sonoff 4CH Pro):


Step 1. Ensure that your account with eWelink is properly setup and running

Step 2. Install eWelink on an Android phone (borrow from a friend if you dont have)

Step 3. Download eWelink on the Android phone and sign-in with your login details from step 1

Step 3. At this point, follow the screen setup on the android phone to complete the setup.

Step 4. On your iPhone, login using same details as in Step 1

step 5. Refresh Your screen on the iPhone by pulling down as usual and there seats your added device.


Note: 

1. Deleting the app on the Android phone after the setup will not affect the functionality of your device.

2. You will have total control on the iPhone afterwards.


This approach worked for me after 5 devices has been ordered, shipped via DHL Express (China to Nigeria) and 7 solid hours of trial/error. 


I hope it solves your challenge with the device.

STILL DOES NOT WORK. I have iOS 13.5.1. Location services setting “while using”. Pairing with camera. Works for brand new camera. Completely broken when tried to move the same camera to another network. Reset doesn’t do a full reset to factory settings. None of the pairing options work: blue tooth, quick pairing, sound pairing, compatibility mode - NOTHING. Even when connecting directly to the camera's built-in WiFi. Stupid enough when accessing camera’s IP (the gateway) in the browser it doesn’t have a web interface except it shows one word “success”. It would be more appropriate to call this whole thing a big “FAILURE” and STUPIDITY of entire eWeLink app with its primitive and half-baked functionality even when it works. But unfortunately even things that supposed to work don’t work. Too bad. It was a good idea and decent hardware. A total disaster software :(

1 person likes this

@Private do you have an older IOS device older than IOS13?

Sorry not older i mean a device that is less than IOS13

No old devices, sorry. Just new phones with current iOS. It would be so much better if camera had a web interface (beyond just the word “Success”). It would be so easy then to connect to the camera's SSID, login with default user name and password and set up wireless. Maybe even watch video stream from the camera like web cams do. Also LEARN from Wyze Cam. They have one more excellent pairing mechanism (in addition to way better app overall) - the app generates a square bar code on the phone’s screen. Then show that code in front of the camera. It reads it and instantly pairs without any looking for BlueTooth devices and without painfully annoying (and often unsuccessful) sound pairing. Try to learn from your competitors. Wyze has so much better functionality.

yeah i agree the learning method is not great at all i am too far in with sonoff to look at other companies now lol.

I keep my ipad 2 which cant get to IOS13 safe as hell as i bring that out to pair any new sonoff device it works well for me but i agree with what you say.

Hey folks..just lived this when trying to pair an existing known working 4ch to a new router/phone. I’m running ios 13.5. After turning on location services for ewelink, i had to perform a hard reboot of my iphone...after doing that...paired/operates as it should
Login or Signup to post a comment