Start a new topic

EWeLink don not pair dNew devices with iOS 13

After a update at iOS 13.2 is impossible to pair new devices

7 people have this problem

In my experience, and that of others, it does. Try rebooting your phone.
Finally i have fixed the issue for me, had an ipad2 on ios 9 downloaded app and connected all 9 new devices i have no problems at all. So its definitely related ios13
It’s strange. They are aware of the issue. But haven’t done anything about it.

Same issue here, only way I could get it to pair was by using an old iPad running iOS12.

Same issue, 

New sonoff mini device, I tried to pair with an iPhone running iOS 13.2 and I only could pair with a older android tablet.

I think that this issue has been resolved as I can pair with the latest iOS no problem. Have you made sure the ewe app can access your location? For some reason, this is required.

1 person likes this

@Robert Band I've all the most recent versions at the current date (iOS and eWelink app). I didn't enable the location services but now I don't need to pair the device because I used an Android device to pair. Maybe next time I can try your suggestion

I did try the location service with no joy before pairing with an older IOS device.

So i dont think unless i done it wrong the location service fix is a fix?



1 person likes this

Same here, enabling location services made no difference. 

Strange - because mine now works perfectly. No issues at all on latest iOS and App.

Very lucky then I guess. I've tried 3 different Sonoff devices.


I have a few more devices on the way so will give it another go.

I've had this happen to me twice now - each time the solution was to disable/re-enable location services, then reboot my phone, then immediately perform the pairing.  Rebooting seemed to be key.

Same here. IPhone X with iOS 13.3.1 I tried restart my phone, restart sonoff mini, with location permission, without location permition, I tried connect to device's wifi... Nothing works So, I have 4 new sonoff devices that I can't add to ewelink app. I will not buy an android device just to do this. And now???
It will work with an older iphone or ipad that is not on IOS13. Its always handy in the world of smart home to have an older device.
Login or Signup to post a comment