Start a new topic

How to control Sonoff over Internet?

Hello,


I am new to using Sonoffs, new to this forum and this is my first post.


I have a Sonoff 4CH Pro R2 that I ahve set up to control 3 different devices all running on 12V DC.


I have got them all working fine controlling them through my Android devices when they are conntected to my home WiFi network. That's great but I need to be able to control these devices when I'm away from home too. When I turn off the WiFi on the Android phone  and force it to connect to the Internet over LTE, I get the "Network Unavailable" error message.


If I logoff eWeLink and try to logon again when not connected to my WiFi network, I get a "Login Failed, Please Try Again Later" error message.


Am I missing something here? I thought you were supposed to be able to control these Sonoffs remotely over the Internet. If you can't then they're not of much use. I can control these devices manually when I'm at home so being able to control them with the Sonoff only when I'm within range of my WiFi network defeats the purpose of using them.


How can I make it so I can control the Sonoff over the Internet via my phone's  4G/LTE connection? Where are there instructions for this?


If it happens to be important, I am located in Canada and my cell phone provider is Virgin/Bell.


Okay, I did that and got the WiFi symbol on the Devices page. Still doesn't work. As soon as I turn off WiFi on the phone  or walk out of range of the WiFi and force it to switch to LTE I get the network unavailable message. Any more ideas?

I would get a smaller sim card to test directly on the newer phone to get me out of doubt. Later you can get a sim card adapter to continue using this new sim card in the older phone.

I ordered an adaptor off eBay yesterday. I expect it to arrive in a couple days. I will cut my micro sim down to a nano sim so I can try going through LTE with Phone 2 and see what happens. I'll report back when I've done that.

Okay, I got the sim card apaptor today and cut my micro sim down to a nano sim and put it in my other phone running Android 8.0. Ran eWeLink. Can now control Sonoff over wiFi and through LTE. It appears then that there is a problem with eWeLink and either my other phone (a LG G4 H812) or Android 6.0. I'd like to get this working on that G4 as it is my main phone. This other one I'm just using for streaming music off my NAS drive because it has a great DAC in it, Where do we go from here?

I put the sim card back in Phone 1 (the LG G4 running Android 6) and tried running the Sonoff with it. As before, I could control it when the phone was connected to my WiFi network but could not when I disabled WiFi on the phone and tried connecting through the mobile LTE network. This definitely proves it has nothing to do with the LTE network I'm on or any of my settings within eWeLink as the settings are the same on both phones. I think it has to be something to do with the fact that Phone 1 is running Android 6.0 and Phone 2 is running Android  8.0. Too bad there's no OS upgrade available for this (Canadian) model of the G4. LG only put out an Android 7 upgrade for the Korean and possibly some European models of the G4.

You can open a support ticket in this webpage explaining all the details about the issue. Support will intent repeat the issue and probably find out some fix for ewelink under Android 6 if there is any. When you have any news please post it.

Hi Roger, I too am a Sonoff newbie having received my first TH16 two days ago. My experience so far, I set up the switch using a Google nexus7 tablet running Android 6.0.1. it went reasonably smoothly but occasionally I got the same failure messages as you but by repetition all worked in the end on my local home WiFi router. I then tried controlling via the phone network on an ASUS Zenfone5. That worked well. I have just taken my tablet to a family members home and used it to control the TH16 via their wifi. I monitored the results switching a light on and off on a security webcam operating on my home WiFi. The temperature reading function appears to work too, still got some experiments with that to try the inbuilt thermostat function option. The instructions and messages are difficult to follow and need some interpretation but by perseverance I've been successful so far. My forum question that I've had no response to so far is are there any issues with operating accross country boundaries, I am hoping to use this device to help a friend monitor and control his pool equipment at his holiday place in France from the UK. If anyone reading this can help answer please do. Good luck. Nige
Login or Signup to post a comment