Start a new topic

How to control Sonoff over Internet?

Hello,


I am new to using Sonoffs, new to this forum and this is my first post.


I have a Sonoff 4CH Pro R2 that I ahve set up to control 3 different devices all running on 12V DC.


I have got them all working fine controlling them through my Android devices when they are conntected to my home WiFi network. That's great but I need to be able to control these devices when I'm away from home too. When I turn off the WiFi on the Android phone  and force it to connect to the Internet over LTE, I get the "Network Unavailable" error message.


If I logoff eWeLink and try to logon again when not connected to my WiFi network, I get a "Login Failed, Please Try Again Later" error message.


Am I missing something here? I thought you were supposed to be able to control these Sonoffs remotely over the Internet. If you can't then they're not of much use. I can control these devices manually when I'm at home so being able to control them with the Sonoff only when I'm within range of my WiFi network defeats the purpose of using them.


How can I make it so I can control the Sonoff over the Internet via my phone's  4G/LTE connection? Where are there instructions for this?


If it happens to be important, I am located in Canada and my cell phone provider is Virgin/Bell.


I should add to this I'm using the lastest 3.3.0 firmware and the latest version of eWeLink

You surely are connected with the device via LAN.  Disable this in eWelink. And the device must always be connected to wifi modem. You should be able control the device via LTE/4G. If not, there is some trouble with pairing. Delete device in eWelink and try to pairing again.

I have one sonoff 4ch pro, one basic and one duo and all of them can be controlled far away from home.

And test if the modem is connected to internet. When LAN is enable in eWelink you can control the device even the modem is on and is not connected to internet.

Other thing you can do is refresh eWelink screen when "network unavailable" message appears. In the screen of devices in eWeling touch with finger the screen and drag it down. It should appear "refresh success" message. And test again.

There would be a good button to do this. When I'm at the end I have to scroll up to recover.

My modem is definintely connected to the Internet so that's not the problem. I'm also not operating in LAN mode. This is an old phone and only running on Android 6. Could that be part of the problem? I looked through the permissions and it appears that eWeLink has permission to access mobile data so that's not likely the issue either. I just can't logon to eWeLink  and I can't operate the Sonoff unless my phone is connected to my WiFi. Refreshing eWeLink screen doesn't seem to help either.


I also tried deleting the pairing and did the pairing again. Made sure LAN mode is disabled. I even tried uninstalling and re-installing eWeLink. No change.


Why does everything always have to be difficult?

Could you post some photos of device screen of eWelink and settings screen of device?

Here's an interesting development. I have a more modern phone (Phone 2) here that runs Android 8.0. I just use for streaming music over my network. I don't have a sim card in it.  I was going to put my sim card in it and use it to try and control the Sonoff but it takes a smaller size sim card than my phone so I couldn't do that.


So what I did was take both Phones 1 and 2 off my home Wifi network, then made Phone 1 a Wifi hotspot and connected Phone 2 to it. I was still using Wifi but signals going out to and iTead's servers were going via my LTE mobile network and not my home WiFi network and home internet provoder. Working this way, I was able to communicate with and control the Sonoff with Phone 2 via the mobile network.


This tells me that the problem does not lie with my cell phone provider blocking communications with iTead's servers or the firewall on my router causing problems. I think that then indicates that it's a permissions problem on Phone 1 or maybe some incompatability between eWeLink and Android 6.0. Does anybody know what the problem with 6.0 might be and if there might be a workaround?


Unfortunately, there's no way to upgrade Phone 1's OS to Android 7 through official updates. I'd have to root the phone and hack a modified/hacked version of 7.0 into it. People have done it but I don't think I have the skills and knowledge to do it.

The Android version does not seem to be. eWelink supports Android 4.1 and later.


I was trying to recreat the issue in my device. I just failed to conect with wifi disable on the cell phone when 1) mobile data disabled. 2) Network mode is not in 4G/3G/2G auto. If cell phone is connected via 2G (or only GSM), it appeared "network unavailable" message.


Do you have some firewall installed on cell phone?

Sorry. I had not read last post. On one hand, good news.

Here are the screenshots I think you asked for. On the settings menu, I also tried with the LAN Switch and Turn Off Network indicator buttons in the off position and it made no difference. If eWeLink put itself into LAN mode, how would I turn it off? Just after I had first paired the device, eWeLink flashed a message saying it was going into LAN mode but the setup menu on the devices screen did not indicate that it had done that because the menu option said Enable LAN not Disable LAN. To be safe, I enabled LAN the disabled it again.

In Device settings you have enabled LAN switch. Disable it. You can realized that it's in LAN mode due the small signal in the upper right corner of device in All devices screen (three small rectangles). When LAN mode is disabled, the signal turns to a signal like wifi (three o four small arcs). Sorry for my English but it's not so easy for me.

Compare both pictures. Yours and mine.

Login or Signup to post a comment