Start a new topic
Solved

Sonoff Mini Not detecting physical switch

Hi,

I've installed a sonoff mini and connected the signal wires to 3 3 way wall switches.


If I try to switch ON/OFF the sonoff using the app, there is no problem, it works like a charm always, but when I do it using the wall switches it just works "sometimes".

For what reasson can it be caused?

Is there any maximum length for the wires?

Should I activate any flag in the app?


5 people have this problem

I have also added 100 nf 50 v capacitor and it doesnt work for me. are we sure its not tasmota related, have i flash with correct file ?

100nF/50V did the trick also for me. Thank you!

2 people like this
Hi, Fran find the solution, but for me doesnt work, but i put 4 capacitor and work. The problem is the power of the interference, the more powerful is, more powerful must be the capacitor. I hope you can solve the problem

Hi AngelB, the capacitor for me solve (in a few times).


Of Course, it helped a lot, but sometimes it still fails. The problem for me, is Sonoff Mini installed with long wire only, i think this a project problem, 3.3V for switch is a very low voltage.

 I also have the same issue with the two minis that recently purchased. I tried with a 100nf(104) capacitor, didn't work. I tried with 2, 3, 4 and 5 capacitors (as suggested in this thread and it didn't work.


Anyone has some other idea? I'm very disappointed.


Thanks!

BTW, this thread shouldn't be marked as "solved". It is not.

Here is like Carnival. 5 rooms blinking randomly. Not nice. 
Just waiting for a real solution or firmware update to sove this.

After I used some cat5 cables to make the connection between the wall switches (read it at another site) it work’s... It reduced a lot the ghost switching, but it still happens... I’ll try to get some capacitors to see if it helps too

I solved all my ghost problems with a single capacitor between S1 and S2.
Everything working like a charm.
I just screwed the capacitor with the wiring, easy busy!

For those who are using tasmota:


First of all, make sure that you are using the correct template in the Configure Template section. You can see it here:


https://templates.blakadder.com/sonoff_mini.html


Also, make sure that it is activated in the Configure Other

I also have the same problem and the reference capacitor 104 did not work.

 

I realized that with the capacitor it takes longer to present the problem.

 

I found that the problem is when the voltage at terminals S1 and S2 is between 2.4 and 2.6V.

 

When this voltage is detected, the switch simply stops working, but after turning it off and on again it works again.

 

I'm using firmware 3.5.0. What firmware are you using?


Thanks

Im using 3.5.0


Try one like this: 

image


I will do a test and as soon as possible I will contact.

 

A very strange thing also happens to me. Sometimes when I turn on the switch of a certain lamp, it turns on another one, this also happens when turning off.

 

Especially if I make three way calls.

 

It seems that there is some interference between the Mini Sonoffs

 

Is this problem related to that too?

 

My wiring diagram is correct, according to the installation manual, considering 1 (S1 or S2) wire for each switch for each three way circuit.

Thanks

I really haven’t seen anything about interference between sonoff’s, but, who knows right... Check your wiring, I mean, the neutral and the positive, it’s usual the positive go to other circuits... When I get one of these capacitors I’ll test it too
I’m using the capacitor and now it’s ok.

1 person likes this
Login or Signup to post a comment