Start a new topic

Sonoff POW R2 Energy monitor drops to 0 on new update 3.3

I bought 6 sonoff devices and I tried upgrading to 3.3.0 on one device. The energy monitor most of the time doesn't work. It's like stuck to 0 Watt or whatever the last number is there.  Sometimes it just drops to 0 Watt even when the AC is working. 


I'm not upgrading the other devices. How can I revert to previous firmware to fix this? 


17 people have this problem

shit, after 15 hours, stop working again. 


1 person likes this
Two days ago new firmware released 3.3.1 after using this firmware for around 48 hours i feel still some issue is there. Power is sometime showing Zero. After refreshing three to four times it showing correct power details. But after few min power consumption stuck to last seen value like 750 watt even after the device is consuming 150 watt. UPDATES ARE NOT IN REALTIME. THIS FIRMWARE ALSO HAS BUG. VERY BAD SONOFF TEAM.

2 people like this
I have the same problem after firmware update 3.3.1. Monitoring through LAN works faster but I still need to refresh the application. WAN does not work at all in the application, "network unavailable" is still displayed and I need to refresh every 15 seconds. They did nothing but changed the firmware number.

2 people like this

Well, yesterday, after update, POW R2 back to normal, sending updated values about power comsume, but today nothing works again. I think the update not solved the issue.


2 people like this
After testing, the problem is the application or refreshing. If I turn off the application and remove it from memory, restarting it makes monitoring work great but only for about 30 seconds. Only that I see "network unavailable" and so again. I wrote to them and wrote that I should turn off the LAN but it was even worse. I tried with Ewelink 3.5.8 but POW R2 doesn't work anymore.

1 person likes this

@Wojtek
EXACTLY the SAME problem as u said. First i was happy to see that Firmware 3.3.1 will fix all bugs and brings my POW R2 back to perfect condition but its no use.... SONOFF should bring again new firmware 3.3.2 LOL


2 people like this
I wrote to them yesterday. They told me to send a movie because they want to see the problem, so I'll send it tonight. They told me to turn off the LAN on all devices, but I did it without any changes. They should improve the applications because there is a problem with data refresh. I have to delete applications from memory and restart then monitoring works very well but for about 30-40 seconds

2 people like this
Canceling the LAN function causes all problems and returns firmware 2.8.0

1 person likes this
I already told them that everything worked best with firmware 2.8.0 and Ewelink 3.5.8 but they insist that now everything is ok :)

1 person likes this

New firmware 3.3.1 fixing the problem is available :)

We are constantly talking about software 3.3.1 that do not solve the problem and have been available for several days :)

2 people like this

Outch :( false joyce :(

Yes I can conform.... It's solved nothing. How crap engeneers itead have ..... 

So after the update it works so far.
I am constantly showing orange shit "network unavailable" and I still need to refresh applications every 30 seconds. Then it works well pow r2 after refreshing. It happens in the WAN and home wifi. Do you have it either? I am using ewelink version 3.11.0

1 person likes this
Login or Signup to post a comment