Start a new topic

Sonoff 4ch pro suddenly didn't work anymore

I have a sonoff 4ch pro since one year and a half and always worked fine. There were some problems with wifi connection but with new firmwares this was solved. But since a couple of days the sonoff directly does not work. All lights are off and if I unplug the power supply and plug again, the blue light turn on for about 5 seconds and then it turn off and the device do nothing. No button responds and the device seems to be dead. The device worked with DC but I tried it with AC and it does not work either. Any idea?


Hi,

I'm facing with the same identical issue.

Did you find a solution?


Thanks a lot,


Enrico

Before throwing it in the garbage try to load an alternative firmware. Unfortunately if something gets stuck in the software there isn't an "official way" of fixing it.


Estou com o mesmo problema com o meu Sonoff Pro. Acende quando liga e depois apaga. Não responde mais a nenhum comando.

Hello. Same problem here. Did you find any solution?

warm up the wi fi chip with a rework station

Login or Signup to post a comment