eWeLink What's New for Android 3.7.0

Release Date:2019-05-22

What's new of eWeLink Android 3.7.0:

1. Cancel "inching" in software for 4ch pro.

2. Update the user interface of TH series.

3. Other App bugs fixed and optimizations.


Note: If you don't want to use this version after upgrading to V3.7.0, you can click the link to download eWeLink V3.6.2.



Controlling the application in LAN mode is unstable, OFF Line every now and then, it takes a long time to get everything straightened in the application, no operation can be performed immediately, everything lasts. This mode should go on only in the case of no internet which will happen to me once a year and at that moment there is usually no electricity.
Robert and ewelink team. Version of app 3.5.8 is rock stable. Find .apk version of this app, and all will work.

This build also broke something on the RFBridge Alarm/PIR sensors and scene configuration.

 I used to have a RFBridge connected to a PIR sensor. Using the scene configuration I was able to turn on lights or other devices connected to a SonoffRF switch, based on the PIR inputs.

Basically, the PIR detects a "person" and trigger the switch. Worked fine until this update. Not working any more.

Also, one o my T1 switch turn/off by it self,  sometimes start beeping random and the status led start blinking random ( although the wifi is connected and the on/off works from the app e from the device )

Sorry to say that this disappearing of inching is crazy. hundreds of people are missing this features an d it cannot be replaced fully by hardware. And now the link for the previous app version disappeared!

Really I am very disappointed and regret to have bought so many Sonoff. It remains only to flash them with different firmwares. Lots of people are complaining. Itead, did you realize it?


1 person likes this
Alessandro, DONT BE SORRY !! Sonoff devices are great. I have lots of them, but since i saw those problems, i stopped updating. I downloaded version 3.5.8 , and it is ROCK STABLE :) . And also flashing is an option, because there are some great alternative firmwares, in which ALL options are SAME for ALL DEVICES. But my solution was downgrade app, and no more updating, untill there is stable version. And finding old ewelink app is not a problem, not at all.. But it is true, that i did not update firmware on devices also.. So i have inching, as it was..Do little research, and prepare for solution. It is there, you just have to find it, and implement it into your system .

Bogdan, you are right and I already found the roll-back, but it remains the frustration of this change: I didn't feel the need to study other firmwares as the original one satisfied me well. From now on indeed I will start to change. Thanks for your help! 


1 person likes this
Thanks Bogdan, do I need to uninstall an app to install older version, I had a trouble with installing preverious and still using 3.7.0

2 people like this
Hi Artur. Yes, i deleted app. No devices are lost. You have all devices saved in your account. So no need to adding them again. Then download 3.5.8 version, and sign in with your account info, and all works ROCK stable. :)

1 person likes this

Dear Scott, can we hope to get back our INCHING DURATION for Sonoff pro R4 next upgrade?


2 people like this
Enzo, DOWNGRADE the app. Delete existing app and then download old app. 3.5.8 . Then install, then username and password, and you have your inching back.
Thanks Bogdan, it worked.
I know :) You are welcome.
Hi guys, I need to set the inching via software. I need to program the inching for every channel separately. Thanks in advance for your support.

1 person likes this
Seperate inching is not possible in 2 ch devices with ewelink, as far as i know. You have to flash custom firmware on 2 or more ch devices, then it is no problem.

hi the link to download eWeLink V3.6.2. not working

which is the old version?

Login or Signup to post a comment