Start a new topic

Firmware 3.0.1

after upgrading to the new firmware, my device online, but cannot switch on or off using ewelink

5 people have this question

Hello,
I too have the exact same problem!
with the old firmware everything was ok, now with version 3.0.1 the sonoff is online but you can't change the switch!

problem solved by update ewelink application

At me not solved. Basic is at 3.0.1, Ewelink at 3.6.1
It is possible to switch the basic via a scene from a T1-switch. It is possible to switch the basic via Google home and Alexa. But via ewelink I can do nothing. 

I have the same problem with version 3.0.1. I can’t switch on/off the sonoff basic when I am connect on same WiFi

1 person likes this
I have 70 Basic2s switches, all upgraded to 3.0.1, running 3.6.1. On WiFi, most switches work, half a dozen allow me to turn on, but not off. All work well, when I'm on 4G, with wifi turned off. It's faster than WiFi. But this upgrade is supposed to allow LAN mode. No switches are enrolled at all. It doesn't work, period! Why doesn't itead have a beta program?

1 person likes this

I have same problem after upgrade 3.0.1.

Do you know how to fix this problem?

I want to know how to downgrade 3.0.0 if it is can't fix.

I have a lot of devices to update and have started upgrading to firmware 3.0.1 


When I view my devices using the Ewelink app on my iPad Pro, I notice the LAN icon is displayed alongside the devices which have successfully updated whereas all the others (yet to be updated) have the WiFi icon alongside them


The upgraded devices appear to be working properly and can be controlled via the Ewelink app on the iPad or via Amazon Alexa.


Before upgrading the rest of my devices:


Does this firmware upgrade now force devices to connect via LAN instead WiFi as before?


Can anyone tell me what issues this upgrade addresses and/or what improvements it contains?





Update:

All devices including Basics, 4 CH Pro R2 and USB DC5V Relay Module successfully upgraded to firmware 3.0.1

and there is a Wi-Fi icon alongside each device in EweLink App.


I upgraded to firmware 3.0.1 (EWeLink on 3.6.1) - I am facing no issues (am on iPhone XS Max) if that helps.

Just got 3.0.1 on 2/3/4 gang devices. Interlock i like, but I need to use it together with inching. As an example for curtain control. 

Since the upgrade to firmware 3.0.1, I'm having issues with some of my Sonoff RF (not all of them though).

One of the devices does not connect to my wifi anymore. I have to reset it every day.

Another one of my devices does not start in the morning as scheduled (it does turn off though).


p.s. my wifi is turned off every night and turned on every morning thanks to another Sonoff RF.


I did not have those issues with firmware 2.6.


it would be great to be able to downgrade easily.


2 people like this
Hi Gilou, Not withstanding your comment about not having the issue with 2.6, have a look at your router. I have 70+ Sonoff basics. At one point, I had issues with units not connecting and having to reset. When I changed the router from a 2011 Cisco (although 2018 V5) to a Huawei (although a more basic router, a much more powerful processor), it had no problem assigning IP addresses to all clients. As to backward flashing, there's a roundabout way if doing it. Look for Tasmota firmware flashing. It has an option to back up current firmware, before flashing the new one. You can back up 2.6 on one of those units, then use the Tasmota setup to flash your 3.0.1. sorry , I don't have a list no for you

I have https://www.itead.cc/inching-self-locking-wifi-wireless-switch.html and am having the same issues after upgrading the firmware to 3.0.1. 


My ewelink app is on 3.7.0.


I have tried connecting the device to two different routers and am experiencing the same issue.


Removing the power source and reconnecting it doesn't work; the only thing that works is re-pairing the device but it will disconnect from the wifi 1-2 hours later.


Has anyone figured out a solution for this problem? I didn't backup my old firmware so I cannot revert.


3 people like this
I’ve got the dame issue

2 people like this
Login or Signup to post a comment