Start a new topic

No pairing with Asus router

Hi, I am trying to pair several sonoff switches to a Asus RT-AC68U with 5GHZ disabled! The asus router is piggy backed off a SFR hub! I can pair ok with the SFR hub but not the Asus! Both have DNS 119.29.29.29 and both with filtering open/disabled! Any suggestions would be appreciated.


I have an AC68U running Merlin and have many Sonoff switches paired with it.  I doubt the router is your problem.  I would carefully check how your phone is connected when you are doing the pairing.

If the hub is running the same SSID as the router that may be an issue.  Try turning the wifi off in the hub temporarily or use a different SSID on the router.

Hi , I have now managed to pair the module after installing merlin! Only prob now is the unit keeps going into searching every few minutes! The wifi is very strong and I disabled 5ghz but still the unit is resetting itself at the exact same time! Any ideas ?

Possible weak signal because unit in metal enclosure or behind metal obstruction.  Possible wifi interference from another router on the same channel or a nearby bluetooth device.   Try setting  "Group key rotation interval" to zero under 2.4GHz wireless settings.

---

 5GHz does not need to be disabled once the unit is paired, all that does is prevent your phone from being on the 5GHz SSID while attempting to pair.

Hi, Tried that! No difference! Unit is sitting next to the router, all elec appliances now off! Cant be interference from a neighbor as I have none! Unless the cows have been munching on Bluetooth chips! But still same problem! pulsing in and out of sink at exactly the same time intervals!

I was thinking you possibly had more that one AP in the house on the same channel.  A lot of people make that mistake.  I don't really have much more to add.  I use an ASUS RT_AC68 as my main router and also have two Ubquiti outdoor access points on it.  I have Sonoffs connected to all three APs with no issues.


Disconnecting at a regular interval still sounds like an interference or DHCP problem with the router.  I am assuming all devices have the latest firmware.


I will attach a couple of screenshots of my ASUS wireless settings for what it is worth...


router2.jpg
(51.4 KB)
router1.jpg
(17.2 KB)

Did you solve it?  The solution might help others.

Hi. No not solved! I think my best way is to get myself something like an asus dsl 68u and keep it in house! Something obviously going on between router and modem as now keep loosing internet aswell!.

Modem should be in dumb mode or passthrough mode.  Wifi in it should be turned off.  Modem should be on different subnet like 192.168.2.xxx and the router on 192.168.1.1  Cable from modem LAN port to router WAN port.  Let the router do everything like DHCP, firewall, feeding any ethernet cables, etc.


I have virtually the same setup as you with ADSL2 modem and RT-AC68U router.  It will work well if you can get it set properly.  I will attach my WAN settings.  The DNS servers can be left on automatic, the ones I use are associated with my VPN.

router3.jpg
(48.8 KB)

Hi EW! Still no joy! I went back to the modem and tried what you stated, But no joy! I went down the 192.168.2.xxx route but not possible cos the hotspot on the SFR modem is at 192.168.2.xxx and cant be changed very limited modem without even a bridge facility! so went for 192.168.0.xxx still no joy! The Sonoff devices will pair with my phone in compatibility mode but not with the AC68U's. Im wondering if Location services could have anything to do with it as we are in a GPS black spot?. I also disabled my X10 Homevision controller and modules because having so many I thought would be causing a lot of interference! But no still no good! Wifi analyser shows no probs and a really great signal to! So the dilemma is do I shell out for a new DSL modem or opt for the Wink 2/Smart things hub route? I am also using Google home hub and Harmony hub ultimate, Ideally I would like to tie in the X10 as well and gradually phase them out. Any advise would be appreciated!....Cheers.


I am also running several Echo devices and a Harmony Hub.  My poor router has about 60 devices connected to it!  With the "Cheers" on the end I am guessing you are down under somewhere and I am in the US.  I don't know if that makes a difference on the Sonoff's or not but I think the wifi channels are the same at channel 11 and below.  If you are on ch. 14 that might be a problem.  The GPS on/off in the phone should not matter else it would probably make you turn it on.


You could try running the AC68 in AP mode and let the modem do all the DHCP and routing.  Not the preferred way in my opinion but it might give you some insight into the problem.  If it works that way you would know that it isn't a radio issue with the AC68 but rather a DHCP or double NAT networking issue.


Perhaps someone else will jump in with a suggestion or solution.  I am out of ideas.

Hi EW, No im actually in France but London born! Thats where the cheers comes from!. As for the GPS the Ewelink does ask me to turn it on but we get no signal here, So im wondering if that may be part of the problem? I did try the AC68U in AP mode before messing about with the modem and that was the only time I managed to get one unit to pair that being a TH16 but that was only briefly before dropping out. I think my best bet is to get a new DSL modem as  this SFR modem has very limited function, Not even a bridge function!. Unfortunately wont be this week as HER indoors is not happy ive purchased over a hundred units that I cant get working! Which ever way I must find a solution as my now obsolete X10 network is slowly dying and it is no longer possible to get my hands on new LD11/AD10 modules! I now know that the smart things hub is limited to USA/Canada and Wink does not support  Sonoff yet without a lot of flashing! It amazes me that no one has produced a simple plug and play device to control the Sonoff units via the router! Especially as these units are so popular!. Wink 2 would be perfect for my situation and maybe in the future will be added to there ever growing compatibility list. Until then i will keep trying different set ups with the AC68U's and try and work out the problem. Whatever the out come is I will keep the forum updated in case someone else comes across the same problem. ..Cheers for all your suggestions matey!......Mark in Normandie France.

Hi EW, Finally got the sonoff's working! But not happy with the scenario! I added a Asus dsl ac52u instead of the SFR modem, But it made no difference! still couldn't pair them so went back to the SFR modem. Now using the Asus routers as AP's but the sonoff's will only pair with the wifi open! As soon as I go to WPA2 personal with any of the routers the sonoff's drop out! Luckily being in the middle of nowhere with 2 foot thick stone walls security should not be a problem! Unless the cows are getting tech savy! Anyway now atleast I can start swapping over the X10! If you think of any solutions to the open wifi I would be interested! Cheers for the assistance mate!........Mark.

Wow.  No, I don't know of anything right off hand.  I have never had a problem with any Sonoff pairing with my Asus routers, dd-wrt routers, or Ubiquiti APs using WPA2 AES.  I use a simple all text password.

Login or Signup to post a comment