Start a new topic

Ewelink and IFTTT not working

Hello, I have some IFTTT Applets using Ewelink smart home service, but lately all those applets fail and say "There was a problem with the eWeLink Smart Home service.

I already deleted the applets and created them again, but nothing works...

Can you help me? 

(37.1 KB)

6 people have this problem

I've had this problem for two months now. The eWelink devices fail to trigger the IFTTT applet. I have a lot of customers having the same problem too. Unfortunately, eWelink say I should just delete everything in IFTTT and recreate it (this is not helpful as there are thousands of applets between my customers and I), they also will not consult with IFTTT directly as this is clearly a service issue between the two companies. I have emailed IFTTT support numerous times asking for their assistance to look into this... get this for a response from IFTTT support: "Please stop emailing us, you are now spamming us". Yup, that's the height of IFTTT support! So unless everyone using this service tries contacting them and eWelink to push them to contact IFTTT, nothing will be done. My two pieces of advice for you. Email them (I'll post the email addresses I've used below). Or try using the stringify or switchur service instead For new customers I'm using switchur, the existing customers I'm having to migrate one at a time. If you use IFTTT, then be aware that if you have any issues, they're not going to help! Here's the email addresses I've used:,,,,,,,,,

1 person likes this
Thank you so much for your answer! But how can I use my ewelink devices with switchhur? I want, for example , when I turn on my bedroom ewelink devices , do something else

Hi, I have the same problem. I made a new IFTTT account and I've still the same problem. I can connect, but then it shows "no Options" in the dropdown, where I can choose the channel.

That's really said... this is a good product, but EweLink is not so powerful without IFTTT

Pues a mi me funciona todo perfectamene, pero hay dias q no me hace ni caso. Porq ocurre? Es internet lo suficiente rapido? One day yes. One day nou. Cuando no funciona lo dejo por imposible y al dia siguiente va de maravilla. Un saludo. Vicente
Bruno, what you need unfortunately requires IFTTT. Unfortunately, the only people that can help are the guys over at IFTTT, who are completely useless! So, let's just hope we can find a competitive service soon. In the meantime, when buying products, just look for those that run on stringify. When I've had problems with stringify and emailed them, they respond and help, something the guys at IFTTT can learn from. Just look at what stringify supports by clicking the Add button, and just buy compatible products. Sonoff will lose out because of this, but unless they can force the hand of IFTTT to do something about it, we're stuck with garbage products!
Unfortunately that is all true... And I bought 2 sonoff RF bridges to use the PIR sensors... That I regret now

boa tarde!


Tentei integrar o IFTTT com o EWELINK, mas quando se trata de criar a função, não é possível encontrar o equipamento Itead, como você pode ver na imagem anexada.


Eu preciso resolver isso em breve, porque eu tenho toda a casa com esses equipamentos.




I got the answer from support that sonoff RF bridges are simply not supporting IFTTT.

It would be no big problem, if they make their API public for sonoff, then users will find other solutions.

That's strange, they told me 2 weeks ago that it would be by the end of November

that would be really great. 

Is working with all but for  real with nothing is working ... first 5 day after o recieve a sonoff i try to connect it with google home with my android 6+ .... no success .... another 5 day after i bought a Home Mini .... but still trying to connect .... no i try with IFTTT voila .... NO SUCCES ... and the answer from you .... DO A FEEDBACK TO GOOGLE ... i tell you something itead ... do it for usu YOU

Seems to be a problem again.

1 person likes this

For me is not working from this morning, is completly down, does anyone know this is an issue from IFTTT or from Ewelink ? 

From this morning i can’t use my Sonoff switches fro IFTTT: no error reported, but “No option found” in every dropdown in all Ewelink applet. The Ewelink service in IFTTT is active, i tried to edit the account to reconnect IFTTT to Ewelink: sucessful logged in, but still not working
Login or Signup to post a comment