Start a new topic

Troubleshooting ifan02 and remotes

Hello I have multiple ifan02 devices running perfectly through the ewelink app and they are great! One problem. All of the remotes I have none of them.connect or pair to the controllers. They all flash red led on top when a button is pressed but they never pair or control the unit. No beeps happen. Any ideas? Purchased direct from the itead website with latest firmware

1 person has this question

You might need to re-pair each remote to a controller. It's not hard to do, just akward. Take the battery out and open each remote. You will have to hold the remote, with one hand hold the battery in place, press the silver button above it until it is a steady flash, then power cycle the fan you want to pair to the remote. Test the remote. If it works, put it back together and then do the same on the remaining fans.

2 people like this


How do I power cycle the ifan02? Could you explain 'power cycle'?

Power cycle means to cut power to the fan control box. Either by switch or breaker.
I'm having same problem, unable to connect remote controller, kindly help
I have exactly the same problem. Once the silver button on the top of the battery is pressed, the LED flashes up to 11 times. It does not matter if I keep it pressed constantly or I pulse it once, it does exactly the same. Then I turn the fan unit off and on, try the remote control and it does not work.

I am having problems linking the iFan02 to eWeLink.  I get to the point where the device starts beeping (3 beeps: 2 short and 1 long), then go to the eWeLink app to add it. But eWelink never sees it and times out. I've also tried the AP method without success - in fact, my iPhone doesn't even show the ITEAD SSID. It seems as if the device is not transmitting its SSID, or perhaps, not transmitting at all. Any suggestions to get it working?

P.S. This is the 2nd iFan02 device I'm installing. The connection to eWeLink with the first was a little iffy at first, but within a few tries it connected successfully. Not sure the 2nd one isn't cooperating.

I, too, have a failed/uncooperative remote for an iFan02.

Thinking the battery was weak, I replaced it and now the remote LED flashes constantly.

Removed the PCB from the case and followed the instructions/hint above, to no avail.

The remote appears to be defective.

What's the next step??

Thanks Catesjadroid your comment is ok

Where on the website is there a way to order a replacement remote for an Ifan02?

So, how does one secure a replacement remote for an ifan02??


i have tried to pair but it's not working

any suggestion?

I ran into a couple of problems, here's how I solved them: 1) When I had wifi extenders in use. Unplugging those and letting the ifan02 and my smartphone connect directly to my wireless router solved this problem. 2) Another problem I ran into was that my smartphone kept connecting to the 5 ghz band of my router, while the ifan02 only connects to the 2.4 ghz band. After I turned off the 5 ghz band on the router, forcing my phone to connect to the 2.4 ghz band, I was able to make the connection between the phone and the ifan02. Give either or both a try, I'm sure one of those solutions will work for you.

I have exactly the same problem. when i press the battery the light is on until i press sound button or paring button, then i press the silver button, and repeat the same option around 15 times and the remote not sinc, do you have any option?

Seems that no one at is listening.  All I ask for is a means to order a replacement remote, and I get ignored.

Not a good business model.

Login or Signup to post a comment