Start a new topic

Sonoff Switch "Network Unavilable" Problem


I have 2 Sonoff Switch

a). Sonoff Th16 (Purcchased it from Amazon UK)

b). Sonoff Simple  (Got it from Ali Express)

I have issues that in EWelink it often says "Network Unavailable" And after few minutes it start work, Some time it says offline.

All is happening automatically and kept repeating whole day.

Internet is Stable and no issues in it.

Not sure whats issue?

is there any current maintenance or Repair work going on in

Can you please check is it common for all users from last 1 week.


7 people have this problem

Same here, opened a ticket but no reply/rectification for last week or so

This happened to me as well. What I have find out is that the WiFi router is too far away, so what I did was to get the WiFi closer to the Sonoff unit.


same problem for me from italy...


Still waiting for reply from Support, As one solution i tried is if you click in right "..." and click Enable LAN it some time gives a push to work for some time.

Not able to connect device and server. Some time connect but most of the time keep on blinking. Dont understand that is that temporary issue or not. Can anyone advise?

This is their server/backend problem which they have not rectified and they are not responding to tickets too. I request all to open complain tickets and post on their Facebook page and Twitter.

As for "Enable LAN" thing, it sure works, though erratically BUT the problem is that it is just to turn off/on and doesn't work for automation or remote control like IFTTT etc

I am also facing similar problems. Very frequently, the EWeLink says "Network unavailable". My all other gadgets are working fine.

1 person likes this
Yes I can set up everything place the wi fi switches in the ceiling and nothing will work.i have added a extra wi router but will still not work and can’t get the light switches to over ridge this error either. Please help

I have the same issues of couple of my working Sonoff.  Some still working before and some no network now.  I try to pairing on does not found.  Then use AP mode pairing it found it and add new device again after remove it.  But when I open the eWeLink app, it stated no network connected but the device show up.  Have open new ticket but no respond yet.  Maybe the Sonoff unit bad or server problem?  I am thinking flushing the firmware and new MQTT to host my Home Asistant server.  That way do not use eWeLink at all.

 this is email from support ((((support don't understand problem !!! god help me!!)))) :

Dear Boot8024l,

Sorry for the inconvenience and late reply.

For device offline issue, please check out this answer

Maggie Wong

Could you send the screenshot when you ping and

Please see attached Screenshot

image have 100% packet loss

Login or Signup to post a comment