Start a new topic

Firmware updating stops at 90%


I have problems updating, it always stops at 90% I already tried in all the recommended ways. Is there any problem on the servers?


5 people have this problem

Não consigo atualizar o firmware 1.8.1 para o 3.0. Quando chega a 90% para o download. Me ajudem por favor.
Thank you for your advice, but this solution has already been tried, with no success. Thanks again.

solution:

Place the lamp next to the router, set the router to 2.4 GHz and run the update again. transfer and works ;-)

--> put the lamp next to the router, the Wi-Fi connection is not so good at the lamp!


(I also had the problem with 90% when updating, The lamp was too far away from the router)


or other Problem:

Sometimes you have to wait a day or two because the server on the internet is not working properly.


Greetings from Germany

Same problem here... All stuck at 90% Did all the tricks, deleting, resetting etc. The problem remains. If this is support, why is it only frustrated customers that answer each question in here? Where is the real support?
what's the newest firmware for the S31?

At first it says I can update, then after over 10 tries of just hitting 90%, the following day it says my 1.0.0 is actually CURRENT!  I don't know what's going on.

my S31 (US) is 1.0.0 and won't update to 2.7.0 


anyone else?


Ich hatte auch das Problem mit dem Update mit der sonoff RGB-Lampe. immer bei 90% gestoppt. Ich stelle die Lampe direkt neben den Router, setze den Router auf 2,4 GHz und führe das Update erneut aus. ging durch ;-)

Thanks for replying again.

Yes I did what you did.

I have tried a few times. Some of my sonoff's work on the 1st press, others on the 2nd BUT for 2 units no upgrade.  An an aside some would only connect to one of my 2.4 ghz networks and not the other network I also have. Tablet is always connected to same network as switch.

As stated in earlier post they still work ok so will leave them be.

i was also stuck and could not update. did you try connecting by pressing the button twice? i mean first there will be 2 short blinks and 1 long, dont connect to that, again press the button for 5 secs then green light flashes rapidly... then try connecting, it registers as first generation device .. then try updating... follow the video i posted above and try updating, it works

2 I have are stuck on 1.7.0

Method above does nothing to help updating .

I am now using them to remotely tun on/off table lamps.

They still work ok so nothing lost. 


check if you have connected input live and neutral wires properly. then if you have the firmware to 1.6.0 then use compatible AP mode by pressing the sonoff button for 5 secs and again for 5secs until you get fast bkinking green light. then update the device then dete it and add it again in simple touch mode... that will do the job :) follow the video below... https://youtu.be/iCRq5obr_SE

Tengo el mismo problema en un T1 EU. Y en 2 basico lo mismo pero dejaron de funcionar. No funcionan los básicos, no encienden, no activan el rele.

I have the same issue on 3 devices. Has anyone managed to sort this issue?
I've got 8 devices 2 of them won't upgrade . Both stop at 90% Tried all the tricks, reset, turn off then on, close router, diff network. Just won't :(

1 person likes this

I am facing the same issue. Updates stops at 90%. Router is close by. Anyone got any luck in updating firmware from 1.8.1 to 2.6.0

Login or Signup to post a comment