Start a new topic

i cant upgarde sonoff pow firmware from 2.0.4 to 2.6.0?

i tried a lot but not success. i delete device and readd and tried to upgrade. reset android software, but never success. i have 1+ sonoff pow. what sould i do?

1 person has this question

Unplug the device from power and plug it back. Try upgrade again.

I have same issue and I'm not able to fix it as well. Somebody something to add to this?

In the same boat, unable to upgrade from 2.0.4 to 2.6.0.  After attempting the upgrade, the sonoff goes offline for a bit then comes back online and reports that the upgrade failed.

Error message states, "100022a077Upgradation failed, please retry"

Remove the device from power socket and then try again

As in, reboot the sonoff (kill power to it then turn the power back on)? My sonoff isn't actually powering anything at the moment, it's just used to measure temperature and humidity%.

Thanks though, I'll try this evening.

Mine has no device connected as well. Just use it for temp, humidity monitoring and was unable to upgrade. After unpluging it from the power socket and then plug it again, upgrade was successful.

Thankx for the information, I was able to update the firmware. :)

Same issue. let me try by power off and on again

Killed the power then plugged back in again and the upgrade was successful. It worked!! Thank you!

ho inserito il firmware di tasmota vorrei ritornare con ewelink posso ricevere il vostro firmware originale


i will try the solution.

Today I have tried the solution of power off restart cycle but the upgrade is still failing for SONOFF POW. 

Login or Signup to post a comment