Start a new topic

Registering, but not going online afterwards (what worked for me)

Hi there!


I recently bought a number of sonoffs. Pow R2, 4 ports R2 and now latest a G1.

I will describe as much a possible. Maybe it helps others... :)


I recently bought a G1. I could not get it to pair. Because I got others to work fine, I thought it was the wireless router in the living room. I moved to an older router on another part of the house and started over there (different brand, different network settings).

It worked immidiately. 
I also firmware updated..crashed at 90%... but it still rebooted and worked afterwards, so I thought "I will update again in the living room")




Then I moved back to the living room and put the SonOff next to the router there and it would not connect to my WiFi there..... I tried to pair again, but then it would register, but not pair.

I then started reading and read all the horrorstories that it could only connect to the first router it was connected to, but no others and that there is no real factory reset, etc, etc...

I then tried to connect to the old again. Did not work either..


Pissed off, I went to bed, and started over this morning. I then looked at all the settings in the router. WPA or WPA2.. WPA/WPA2 (combined mode).

Different network name, different frequencies/channels, Guest network,...NOTHING worked..

I also checked that I could reach the SonOff server, ..nothing..

Then I read that the "two blink..pause...two blink" means it has access to the router, but not to the internet...
I also read that many people had this problem after a firmware update and blame SonOff that they have not fixed it.

That got me to think that it could be a DNS problem... Tried a DNS server that SonOff recommended...Nothing.. no difference..


It would still register, popup in the app as offline and stay offline there...


Then I thought about the recent past. Did I make any changes in the network lately? Would that matter?

So then I realised that I changed my subnet mask from to, because I have two networks at home that need to talk to each other (192.168.0.x and 192.168.1.x).

What would it matter? It is still an IP standard...

I then changed my netmask to on the DHCP settings on the router ..rebooted....and... guess what...I worked immediately again!


So... the moral of the story. Check not just WPA/WPA2/2.4Ghz/TKIP or AES (by the way, my sonoffs did not care for whatever those settings are, but it is worth a try if you have problems).

Also check your ip address, ip gateway, DNS, ...
(Maybe just change it into a known standard/often used settings, like a ip range from, as a gateway, as a subnet mask and + as DNS servers)


Good luck people :) I hope this helps someone.

1 Comment

by the way...afterwords, I changed back my subnet netmask. Everything kept working. It is just when registering that the settings have to be "just right" :) 

Login or Signup to post a comment