Start a new topic

How to factory reset Sonoff touch?

I changed my router and kept my SSID and password same but Sonoff touch (3 gang ) is not connecting to the new WiFi . I am not able to enter quick pairing mode no matter how many times I try to press and hold the left most button. How can I factory reset this device, so that I can start a fresh.

14 people have this question

I THINK... sometimes.... but that's another story.... bearing in mind I do not have any iOS devices so cannot confirm but you do not connect your phones wifi to the access point the sonoff switch enables but let the application do it when using the *compatible* pairing option not quick pairing.

You'll know if it's reset if the access point on the device is enabled. In configured mode it is a wifi client not an access point. So reconnect to your real 2.4GHz only routers wifi Make sure you do not connect to the 5GHz SSID if your router has it. Tell your iPhone to forget the Sonoff access point and then re-open the app and find your way to the necessary pairing options... I cannot help you with that because I have never used or seen the iOS app, sorry. Hope you can figure it out.

Okay, finally got it working after re-reading some of the other comments:

* Reboot the switch (TX Switch has a reset button on the side which reboots the device)

* Long press the touch button on the switch, > 5 seconds; switch goes into 'quick-pairing mode' - short-short-long LED blinking

* Release and long press the touch button again, > 5 seconds; switch goes into AP mode (rapid blinking of the LED)

* Go to your mobile device WiFi settings and connect to the ITEAD.???? WiFi (That is the switch's SSID), Password is 12345678

* Open eWeLink and select 'Compatible Pairing Mode (AP)'

* Enter your 2.4G WiFi Password - I Found that I had to connect to my own WiFi first, open the eWeLink app so that the correct 2.4G SSID is 'selected' in the app settings, and then exit and connect to the ITEAD WiFi. If your WiFi setting in the eWeLink app shows ITEAD it will not work as that network is not connected to the internet, it is only for connecting to the device, you are basically telling the device what the SSID and password is for your network

* Hit the 'next' button and wait for something to happen, at some point it should connect to the Internet using the WiFi settings you supplied.

The process is very pedantic.

The only remaining problem I can see after performing a reset so that the ITEAD-* access point is started is the firmware chooses a stupid and wrong channel for the access point. It chooses 2.4GHz channel 7 and if there are nearby access points on any other channel from 5 to 11 but not 7 they will interfere rather than co-exist. I have a strong neighbouring AP on channel 6 so I currently cannot successfully compatibility mode pair since the Access Point is on a channel that conflicts with nearby strong adjacent channels. The developers should have chosen 1, 6 or 11 only and never the intermediate channels.

already try all option here,
change ssid
change password
empty password
each time able to configure using ewelink apps but my switch still blinking once every 2s.

Having the same problem here . It's impossible to pair. Posted in many threads and nobody from technical support is answering .  Problem is with WiFI and also RF is not pairing . Green light blinking three times and then try to pair via WiFi or RF and nothing . I'm thinking is a HW failure and send to garbage and try another brand . Is not reliable after working 3 months suddenly it lost all the configuration . 

Bought 10 TX/US Switches and Im having a hard time with 2 of them (both 2-gang). I've tried quick pairing and also compatible mode for several times and several hours. My network is 2.4G, only letters and numbers on SSID and Password. Tried also on the Guest Network and no succes. Tried to reset on the little hole on the right side of the switch (suposed to be a reset button) and found out that its a fake button. Yes just open the cover and you'll se there is nothing to be pressed inside the hole.

I had the same problem, I have about 15 sonoff devices in my home, I replaced my router, only had a problem with the T1 model, that is what I did:

1. Got the old Wifi router and set up again with a different SSID and different password

2. Added again the T1 with the new SSID and new Password

3. Switch off the old router

4. Power on the new router

5. Setup the T1 again

That worked for me and solved the problem, however of course a reset button or any way to factory reset would be nice next time.

Hope this helps.

I had the issue where it would register but then it would still not show connected.   Turns out the problem was related to me having a $ in my password.  I removed that special character and it fixed the issue.  Let me know if you had a special character, removed it and it fixed your issue.  Originally the device connected to another router okay with the $ however the new router had an issue with the $.

my wifi password using only numbers.

i have tried its not working

Login or Signup to post a comment