Start a new topic

Sonoff POW R2 needs Power on State

I have a bunch of old v1 POWs and they all have the Power on State. I recently bought a bunch of POW R2s and have updated thier firmware, it does not have power on state! I had plans to put the POW on my freezer, fridge and ACs. The devices must auto start after a power outage so I do not have to do it myself everytime. The worst case would be after a power outage I am not at home and everything melts away because Sonoff didn't bother to add Power on State on their next gen POW. We need Power on State on POW R2!

27 people like this idea

Hi WaqasT,
had the same problem - newest eWeLink Version shown in Playstore is 3.5.1.
You can download Ver. 3.5.4 here...
(it's an alterantive app-store)
Then install apk over the existing version. This is working for me.
Best Regards

2 people like this

Thanks Oli,

this has also worked for me and the R2 (firmware 2.7.0) has now the power on state available. It also changes the layout and menu structure of the switches slightly. The wrong symbol ° has now been replaced with the correct unit kWh, so this is all fixed too.

Seems like this version should be on the official app store!

Thanks again.



1 person likes this
EWeLink v 3.5.4 still not issued on AppStore for ios.

I've updated firmware to 2.7.0

eWeLink on my android is still on version 3.5.1 (from july 16th 2018) and don't have this option. I've uninstalled and installed from zero, but the version on my playstore is still 3.5.1

I'll wait for the app update on the playstore, I've never tried, I prefeer to wait the new version on the Android PlayStore ( hope it arrives quickly ;)  )

All your messages were very useful, thanks to everyone

Login or Signup to post a comment