Start a new topic

upgrade firmware 1.8.0

no possible to do an update of my firmware 1.7.0 to 1.8.0 from Ewelink

i got an error message : " Echec de la mise à niveau du firmware"

can you help me, what can I do exactly to do this upgrade ?

thank you 

3 people have this problem

I got the same problem. I've tried everything - upair device and pair it again, downgrade Ewelink, reboot router and some other hints. Since last december all that itead staff works like a crap. AWS servers are very unstable and history doesn't work (they promised to fix it till the end of april). I'm sure that problems with upgrade are their fault but they are not even interested to inform us about that - just a Chinese service.


thank's for your feedback Robert

I can't upgrade from 1.62 to 1.80 Slampher RF R2.

Upgrade reaches 90%

same problem, it reaches at 90%

Hope someone finds a solution

I'm still trying but not successful

after dozens of attempts of upgrade I've tried once again today..... and success!!! They had to change something. I wonder if it works for you as well now.


Thanks Robert,

so I will continue to try to upgrade


thank's for your comment 

you know what has been changed in the 1.8.0 version ? what are the changes ?

I just tried for my T1 EU and was success. But no possible on my Touch model.

I'll try later and I'll let you know

just to inform you that the Touch model running fine in the 1.8.0 version too

Someone knows the changes in the 1.8.0 version ?

After upgrade Sonoff Touch EU to 1.8.0 no light on wifi led.


I still have same issue for 4ch pro. It is always stuck at 90% and then failure message.

1 person likes this
Same issue when trying to upgrade firmware on Sonoff 1ch. It goes till 90% then fails. Any solutions?

1 person likes this

Same issue .  Upgrade fails at 90% on three devices.  

Login or Signup to post a comment