Start a new topic

Unable to add/pair Sonoff device using welink

I have multiple smart switch devices at home, and I’ve been able to add them overtime, however recently I bought several more, and I’m not able to add them following the same process, or other that I found online due to the firmware and app version updates. I though it was something with the new one, so I tried with one that si had before, but was also unable. As part of the process and I’m able to put WiFi information, it detects the device, and indicates in a status “pairing ...” but never finishes this step. Tried different phones and WiFi with no success. Other devices already enrolled are working fine.

1 person has this problem

I bought two touch UK switch and the pairing functions doesn’t work for both switches. Please help with that, I really need them
same problem
Also, same problem
I have exactly the same problem. My 3 old S20 work just fine but I can't pair 2 new S20 I bought. I've even changed the new ones I bought but keep facing the same problem. Any idea on what's going on?
I’ve opened a ticket with ITEAD but has not heard back. Probably others can also do the same. I’ve not figured any work around either. Someone has?
i have opened a ticket too...
After all of back and forth what the support team from ITEAD directed me to do was to pair using an Android device. I had tried from different phones but all iPhone. Using android finally worked! Meaning the problem is for iPhone users apparently...

On my end, they paired fine the first time (Android).  Yet I recently changed my WiFi router, and since then I have been unable to pair them.

The only thing that changed is that after pairing them the first time, I had accepted a firmware update.

Resetting (via the reset switch under the pace-plate) has no effect... my app simply does not detect any of the switches (I have 5 of them)

Same problem was at me too. What helped me, I connected the switch with another network (with another SSID(!), I used guest-wifi from my router). Then I deleted the switch again and connected without any problems to my normal wifi. 

Really thanks for the nice post here have to need got windows clock this is the batter app to using you forever here to set the time to according the work so access the all setting and like to share this post.

Login or Signup to post a comment