Start a new topic

Cant connect to ITEAD-1xxxx SSID

I have a sonoff RF that I bought when it was a new product and has been sitting in a box for a couple of years. Found it again and want to deploy it.

But eWelink will find it, and try to connect to it, and then give up.

If I do the hold button down for 5 seconds thing twice, like asked, a SSID comes up called ITEAD -10000xxxxx.

Trying to connect to it on any device and I cant. Andriod phones just say failed to connect to it straight away, Windows laptop also wont connect to it saying something like it couldnt find the network requirements.

It must have sort of worked once because it came up on the wifi network, but had a slow blink which the instructions were to reset it and try again, which I did and now get the refusal to connect to its SSID when I try.

1 person has this problem
1 Comment

I really appreciate discussing your experience. it helps the user. Recently I have been faced issues while I tried to connect my printer to my laptop then my printer shows offline after that I took assistance from Printer is Offline Windows 10 team and they assisted me perfectly to resolve my issues.

Login or Signup to post a comment