Start a new topic

Sonoff switches won't connect

I've upgraded my router, and discovered that none of my devices will now connect to the new one, in Quick pairing mode it won't discover them, and in AP mode, it will discover the devices, but they won't connect, how do I get around this?


1 person has this problem

Just out of curiosity, is yours a mesh network?

Nope, it isn't

Turn on airplane mode and connect using quick pairing mode (touch).

I can't connect the sonoffs switchs to Wi-Fi. I verified the "10 Solutions to Failed to Connect to the WiFi Router" but the problem persist. I used de pairing proccess and de devices are defined but the status is off line. Do you sugest me another process?

If you cannot connect your device this is due to old first generation hardware that doesn’t work properly with new internet devices because of SSID and PWD combination.

This worked for me with my Android phone in combination with an ASUS RT-AC87U

Create guest network  and name SSID: 12345678 with PWD: abcabcab

Press button on socket 2x 7 seconds in order to let it blink every second.

Pair the device (don’t use compatible AP). After connection update firmware.

Leave the device on for 5 minutes and unplug the socket.

Remove the guest network with SSID: 12345678 and connect with your phone to you own network again. Plug the socket back to the wall plug and press the button on the socket 1x for 7 seconds until it blinks every 3 seconds. On the app select now Compatible Pairing Mode AP.

Now you will see that the device has been recognized as second generation.

 

Took some time to figure it out but it worked.

 

 


1 person likes this

I was not able to connect my device.  Here is what finally worked for me with an Android phone.  I put the phone in airplane mode, then turned on only wifi (but left phone in airplane mode).  Finally I was able to use the standard method and connected the first time.

I found that the failure to pair is device-specific.  From my Android phone I tried different ways of pairing, using different wifi and routers, and it never paired.  I did the same with my Android tablet using the same wifi and router and it paired the first time.  Once the device registered it updated the firmware.  That may have resolved the problem but I wasted so much time trying to pair I'm not going to try it again.

I can view the device with my phone every time and I've not had any similar problems with this phone.  Sonoff just doesn't want to work with it.  BTW it's a Samsung S7

Thank you Mr Nemo, your procedure finally got my Sonoff switch working again! It had been inoperative for 6 months since I upgraded my router Thanks again Steve

I have the same issue but have been unable to fix it. All of my devices upon pairing turn on whe adHoc AP but it only lasts 7 seconds and then disappears. 

Login or Signup to post a comment