Start a new topic

Sonoff 4ch pro button problem

Hi, I have one sonoff 4ch Pro and I have found this problem: randomly when I press sonoff 4 button the sonoff don't change the status, while on the application work properly. Note : if I unplug the power and replug the sonoff work propletly. Solutions? Thanks

Cerchi un interruttore tapparelle WiFi ? La mia guida per Sonoff tapparelle elettricheSonoff 4CH Pro R2 manuale italiano. Istruzioni anche per tapparelle Google Home.


Sonoff tapparelle elettriche | Sonoff 4CH Pro R2 manuale italiano

Hello Massimiliano, i have the same issue on my Sonoff 4ch PRo, how did you fix it?

1 person likes this
It's very easy, this product it's very stupid and I think the developer its insane to make double click to enable rf programmer without a good button combination. The problem it's very simple, when you press one button 2 time quickly the sonoff go in autodiscovder rf mode, search a remote. Command frequency but remain in learning forever and capture any frequency over the air, wifi frame noise included. For this reason the sonoff play on and off automatically, for noise captured and changed for remote rf. Command. Buy a economic rf command and press 2 Time quickly the button zone with a problem, press one button of remote command and play. Message for developer : correct this stupid bug , it's surreal in 2019 this situation. P. S. You my suggestion for free.

1 person likes this

I have the same problem. why you cant fix it? 

that night my garage door opened because of it.

maybe you add a function to disable the RF module in ewelink?

Tenho 5 modulos do sonoff 4ch pro estavam instalados e funcionando muito bem porem mudei a rede e eles parara de funcionar o led azul acende e fica acesso por alguns segundos e em seguida apaga e não funciona nada no modulo nem os proprios botões, alguém pode ajudar?


I have contacted the team, and they suggested to clear the RF code.

I have done the same now its working perfectly without any issues.

if you are having same issue the please do the below procedure , definitely it will works !!!

1) Remove Electrical power ( Both AC & DC )

2) Open the lid ( Open the device )

3) Find out the  S5 button located on PCB board ( Refer url - )

4) Connect Input power either AC / DC

5) Press the S5 button till 4 led showing green light.

6) Now you can Close the device and connect the wiring properly.

Hello, I connect the Sonoff 4 Ch Pro Rev 2 to the power (230VAC) and the only thinks happening is the wifi led turns on, but after 4/5 seconds they turn off. I connect also with 12 VDC, and it's the same. Thanks in advance. Best regards
Anybody found a solution on the button problem? I can’t even activate pairing mode. Tried the s5 switch which resets the Rf but still nothing
Same problem here. Rf reset. Used dc and ac and problem still the same. Anyway to reset to factory standard?
I have the same problem with the sonoff 4ch rev2. I connect to the network, the LED lights for about 5 seconds and then goes out, after that, nothing works, neither the physical buttons. someone managed to fix it?
Don’t bother trying. Get a new one. Can’t be fixed unfortunately
Login or Signup to post a comment