Start a new topic

Can't pair Sonoff SC with BT Hub4

I purchased 3 Sonoff SCs. I thought setup would be very straightforward like the plugs but I cannot pair them with eWeLink. I have iPhone 6. I press the button for 7 seconds to put Sonoff SC in pairing mode (3 blinks and it repeats) however pairing keeps failing. My router is BT Hub4. I BT called customer services and we almost changed all the options for the router, but no luck. Even after switching off smart setup (which was proposed as solution on some sites) didn't fix the problem.  In the troubleshooting bit it says to remove the wireless network internal isolation but I don't have that option on my router. Any help is appreciated as it started to get frustrating. =( 

1 person has this problem

I have just changed the SSID of 2.4GHz channel to make sure both phone and the sonoff sc are connected to the same channel. Fixed the problem straight away.

Did you resolve this problem? I've the same issue.

Can confirm, switching off the 5GHz Wifi during the setup-process and the whole thing worked immediately. After the setup concluded you can switch on 5GHz again.

I have same problem, i emailed ewelink helpdesk, they replied when im out of town. When i came back, i tried all instruction they told me, but after that no reply anymore... a little bit disappointed
Login or Signup to post a comment